Question

Locked

Userenv error 1030 and 1058 every 5 min on domain controller

By jbestor ·
I've tried just about every artical I can find and so far others solved the issue with solutions that didn't solve mine.

I have 2 domain controllers (DC1 and DC2), the errors only occur on DC1 which holds all the fsmo roles.

Just like other posts I get error id 1030 and 1058 every 5 min but it will randomly stop for anywhere from 15min-3hrs. I will also get a random 1704 success message but they are rare.

I have tried all the suggestions in the 887303 KB Artical. As well as anything I could find online. Any ideas?
Thanks

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

seen all these?

by lowlands In reply to Userenv error 1030 and 10 ...

http://www.eventid.net/display.asp?eventid=1058&eventno=1752&source=Userenv&phase=1

Some general troubleshooting steps.
- Run rsop.msc on the DC with the issues. Any errors?

- Run dcdiag on both DC's.

- Run netdiag

Collapse -

Thanks

by jbestor In reply to seen all these?

Thanks for the link. I had tried most of those. dcdiag and netdiag come out fine. When I run the rsop.msc it tells me the computer policy failed "Access is Denied".

I've checked the sysvol share, bypass traverse checking and reset the computer password.

I should note that no wins server is set up and the network only consists of 7 servers total all running server 2003 x64.

Collapse -

sounds like

by lowlands In reply to Thanks

for some weird reason the computer account does not have access to the folder for at least one of the GPO's (computer policy is read by the computer account itself)

Try to create a little batch file that does something like:

dir \\dc\sysvol\gpofolder >> c:\output.txt

save and then run with either the at command or the scheduler. This will run it as system and might show you if that's indeed the problem

Collapse -

Thanks again

by jbestor In reply to sounds like

I ran the batch with the at command. First the way you mentioned and when that worked fine I changed it to:

dir \\domain\sysvol\gpofolder >> c:\output.txt

That failed. The permissions are the same on both DC's and the other DC has no issue.

Collapse -

Hmmm

by astraughan In reply to Userenv error 1030 and 10 ...

Is it causing any crashes?

I am having a very similar error. Every 5-10 minutes im getting the 1030 and 1058 error. but no 1704 issue.

There is a macantosh on the network, that when accessing Indesign or Photoshop files on the server crashes and occasionaly crashes the rest of the network. Other PC's do this, but the crash is always localized, and not as often. Could these issues be related?

Good Luck.

~Naz

Collapse -

Same Issue

by troyedwards1971 In reply to Hmmm

I have the same exact issue as the originator. DCDIAG, NETDIAG, and RSOP.Msc all run fine. It is only happening on 1 DC, and for the life of me cannot figure out why? Sometimes I will get a 1704, but mainly 1030's and 1058's. This is driving me batty! Any ideas?

Collapse -

Fixed it

by troyedwards1971 In reply to Same Issue

I have found my problem! This was the only server popping the error, my 4 other DC's were fine. But I was getting time sync issues within the domain. All my DC's point to the one server that was erroring out for time updates. So FRS was having delays due to time being off. I re-adjusted the time server to point to a valid time server on the dc that had the 1030 & 1058 errors. Once it sync'd the time to a valid source, FRS stopped the delays, and I have not received any 1030's or 1058's in over an hour.

Collapse -

Time screwed me

by CountryChurchIT In reply to Userenv error 1030 and 10 ...

Re-syncing the clock also fixed my problems. Just a +1 for troy

Collapse -

Use dfsutil

by dpiccus In reply to Userenv error 1030 and 10 ...

Go to the command prompt of the computer with the errors and enter: dfsutil /PurgeMupCache, press ENTER and the errors will stop.

Collapse -

dfsutil worked

by preeper.peter In reply to Userenv error 1030 and 10 ...

I had the same problems crop up and only a handful of users were having logon issues. The only problem I had was tracking down the dfsutil. It is hidden in the "Windows Server 2003 Service Pack 2 32-bit Support Tools" download. Once that was installed, using command line ran the dfsutil and eventlog errors stopped. Thx to all.

Back to Software Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums