Using RealVNC with Windows SBS 2003

By bennp ·
I'm trying to configure my SonicWall TZ180 router and RealVNC so I can access a specific Windows XP Pro workstation on a network running under Windows Small Business Server 2003 DHCP. I forward port 5900 as required by RealVNC to the workstation PC in the router. However, i'm not able to connect from home to the workstation. I have a static IP address from the service provider. I think this issue is due to the fact that my Windows server is setup as DHCP controller, not the SonicWall router. Please help!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

An idea...

by tmalo627 In reply to Using RealVNC with Window ...

I'm not sure if your SonicWall is set up the same way as my Zywall, but in addition to the port forwarding, I have to create a firewall rule allowing traffic through that port also. I'm assuming your VPN connection has been set up and is working.

Collapse -

Must be the VPN settings!

by bennp In reply to An idea...

Thanks for your help. It must be the vpn settings because I did exactly what you recommended, but the Sonicwall is blocking the incoming request.... (not blocking the port!)

Collapse -

As stated in other reply, open that incoming port in your firewall

by robo_dev In reply to Using RealVNC with Window ...

It would be more secure to use a port other than 5900. Pick a random high port number, or else an attacker will know instantly that he/she is looking at VNC.

As long as the server has a static ip address, your firewall has the port open, and you have a nat-forwarding rule to forward the correct port inbound (which you do), then it should work.

Related Discussions

Related Forums