General discussion

Locked

Using the WebBrowser control in VB6

By trung_phuongn ·
I have developped an application in VB6 where I have to use the WebBrowser control. My development environment is Win2K professional, my default Browser is Mozilla Firefox. Everything works fine under Win2K. When I install my application in another machine running under Win XP, my application works fine, and display a web page in my WebBrowser control, but some buttons with hyperlink do not work. It does not take the user to another page. The next page is under a secured section of the web site (and yet it works under Win 2K). I have reset all the internet options to the default settings ( for IE and Firefox). Does any one has any idea on this problem ? Please help (the release date is coming real fast)

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by harun In reply to Using the WebBrowser cont ...

1. Maybe css style code problem. Use no style your code. I solve same problem my project. And I have used picture not style in pages.

2. Or javascript problem. Dont'use all style properties in javascript block. Didn't support all sytle command in winxp .

3. Don't use onclick based script. ( Example: this is may be problem onclick="this.style.backgroundColor='Black' "). Use "document.all.elements('??')" type code Use script function in your code .Or use picture .

4. May be has Javascript library problem . Everytime use lover level version jscript language

Good Luck..

Back to Web Development Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums