General discussion

Locked

vgaSave disabled... help!

By pal.man1 ·
Hello,

I like to muck about with computers, and have just recovered my PC after changing the security permissions to the entire c drive so that no one had access :).

No sooner did i have it back than my graphics card refused to install because windows had not loaded with the default VGA driver, mainly because during the install, it asked for motherboard AGP drivers and I didn't have them handy. I looked at what drivers the current display adapter was using, and it said vgaSave.

I went into Device Manager, and disabled vgaSave (under non-plug and play drivers), and now when windows should boot up, I just get a blank screen, but the computer is still working away underneath it. I can't even boot into safe mode or use the "Enable VGA mode" settings under F8.

Please help.

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by statykserver In reply to vgaSave disabled... help!

If you have windows XP/2000 then boot up with the cd and run a repair on the windows installation directory. (not recovery console)

Here is a site that explains this if you have some questions. http://www.webtree.ca/windowsxp/Setup03.jpg

Collapse -

by statykserver In reply to

I think its time to use the ol' trusty fdisk and format commands.

Collapse -

by pal.man1 In reply to

Poster rated this answer.

Collapse -

by pal.man1 In reply to vgaSave disabled... help!

> If you have windows XP/2000 then boot up with the
> cd and run a repair on the windows installation
> directory. (not recovery console)

I have tried that. When the continue setup screen should appear, the computer is doing stuff, it's just I can't see anything.

I have also tried booting recovery console and using:

enable vgasave SERVICE_SYSTEM_START

but when I run it, enable reports that the reg setting for vgasave is already SERVICE_SYSTEM_START.

Could it be because I disabled it inside dev manager instead of using disable?

Collapse -

by HAL 9000 Moderator In reply to vgaSave disabled... help!

Well as you have already admitted to liking to much around with computers I think that you'll be mucking around a bit more you need to reinstall Windows and not just a garden variety reinstall but wipe the HDD and then install from scratch as if you have a new HDD.

Of course this time you'll need all your device drivers so you can learn the Hard Way that Windows is something never to mess with if it's working leave it alone and if it isn't working properly that is the only time to consider playing with it and never under any circumstances consider doing a edit on the Registry.

Col

Collapse -

by pal.man1 In reply to

Poster rated this answer.

Collapse -

by pal.man1 In reply to vgaSave disabled... help!

I managed to fix the problem without wiping the hard drive.

I installed windows on another partition, and then installed all my hardware and drivers on that.

Then I reinstalled that version of windows and took a note of all the dialog boxes that came up, and all the keyboard strokes I made until setup was done.

Then I went into safe mode and again took a note of all keystrokes until I had enabled vgasave.

So then I went into the original version of windows, replicated all the keystrokes et voila... vgasave re-enabled and windows fixed!

Collapse -

by pal.man1 In reply to vgaSave disabled... help!

This question was closed by the author

Back to Windows Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums