Question

Locked

Vista Keyboard Bug

By jhawkins ·
I have a new Dell with Vista on it and the right hand side of the keyboard changes its mapping on and off..

ex.. The CTRL ALT SHIFT keys wont work at all and the ' key will give me an E with a french accent above it...the other punctuation keys in that area also remap...

very frustrating when you are trying to write action script or html and the " key doesn't work

I have this problem on 3 different machines
2 Dell machines with factory installed Vista Ultimate and an Alienware 9700 that I upgraded (and recently downgraded because of lack of SLI driver support)...with different keyboards as well

AND I am just noticing that right now it is doing it in windows mail but not in this window
???? These are supposed to be ''''

Anyway, weird problem...let me know if anyone has seen this before

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Re: Vista Keyboard Bug?

Have you tried to change the language on the keyboard. Go into the control panel and then on to the keyboard icon. If that does not help then go into your "region and language" icon in the control panel, select your language and location. Hope all goes well.
Please post back if you have anymore problems or questions.

Collapse -

Same problem

by newaira In reply to Re: Vista Keyboard Bug?

I just formatted my comp and then installed Vista for the first time. I also have a dell (Inspiron 6400). It doesn't matter what program I'm using after a while it seems that the keyboard switches to French layout (or at least some keys when pressed write french characters as mentioned above). The Language/regional settings stay the same however which is weird. The only way for me to return to the English keyboard layout is to close the program and the open it again.

One thing is for sure, and that's that I am not changing the keyboard layout by accident.

Collapse -

Language/regional settings

When you load on Windows Vista your are given a choice of keyboard languages, you can select which one to use, i think you have accidently picked "French" here. So to change it just goto the Language/regional settings in the control panel and select "English", you will see your beloved "French" marked in this box also, once you have selected the language of your choice you will need to re-start your computer, when logged back in go to Language/regional settings again and select the "French" languge and delete it, this will ensure that it does not reappear and do unjustice to your input keyboard language. I hope this does work for you.

Please post back if you have anymore problems or questions.

Collapse -

Solved!

by newaira In reply to Language/regional setting ...

You were on the right track, but it isn't the language that was the problem, but the keyboard type.

Well I finally figured it out! While the language does not change, the keyboard layout changes. For the English (Canada) language there are 3 available keyboards by default. Somehow, every now and then, I manage to switch from US keyboard to Canadian French. There must be some shortcut key I press by accident. So while I can use Alt+Shift to toggle between languages, there must be some other shortcut I'm accidentally pressing that switches between keyboards.

Anyway, I have removed all keyboards except US, and everything is fine now. I think the reason this didn't happen in XP is because only one keyboard is setup by default.

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums