General discussion

Locked

VISTA suddenly failed to recognize a printer

By titomba ·
This is odd as ****, my vista laptop all out of the blue stopped recognizing my printer, the printer is installed in a windows 2003 server, its shared and declared as the predetermined printer, so, ive been reading all the workarounds here, none seem to work.

When i try to use the wizard, vista wizard asks me to log in using the server credentials.

So i select second choice, printer by name, i write "\\myservername\Printersharename" first time i did this, it popped the window to ask me, to Identify myself, i did and could print, but since the error i cant do it, now just throws an error window 0x0000052e.

I went to the Vista control panel to change the domain name to match the one that my server shows, so far so good, but, then again, i go back to add a printer in Vista, and the same error happens, then i go to the wizard again, look for a printer, next, choose the server where the printer is installed, and to my surprise now asks me to ID myself, i chose the use another user option, and start writing, MYDOMAIN\SERVERNAME\USERNAME and then i enter my password, all to no avail.

Its not like i have any problems accesing it by network, i can even remote access it.

But whenever i try to write my server name in a window, like \\servername the machine asks me to Identify myself.

And same darn story happens, i cant access it, and it wasnt this painful the first time i did it!

Any ideas of what can be done?

Thank you.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

vista printer problem

by jswinberlin In reply to VISTA suddenly failed to ...

have you tried entering the printer share into the search bar? \\servername\printer name or \\servername, then select the printer.

If it then asks you for user and password, type in \\domain\username not \\domain\servername\username.

If it's a network printer, Do you have the IP Address and can you install the drivers locally and print straight through a TCP/IP connection?

Collapse -

Yes i did that as well

by titomba In reply to vista printer problem

Thanks for the advice jswinberlin, its not a network printer, i have to connect it via USB to the server, can it be done by tcp ip? even if the printer is exclusively usb?

Thank you for your interest.

And yes, the address is as well reachable by windows bar, but it asks me to ID myself to no avail, even when i know the settings are correct. Im so puzzled about it.

Collapse -

Access other shares

by Nickgreene In reply to Yes i did that as well

Can you access other shares using the same credentials?

Are you the sole admin? maybe someone else had changed a setting?

Collapse -

Thanks nick yes i can access other shares

by titomba In reply to Access other shares

I can access other shares, even those that are not in the same workgroup but connected to the same router.

Other people can access as well, additionally the XP users, can detect and add the printer, Vista seems reluctant, it can only detect, but cant access.

Thank you.

Collapse -

Vista/7 Specific

by jswinberlin In reply to vista printer problem

Ah, it occured to me that you may have User Access Control enabled on the Vista which is requiring you to authenticate in some way.

See this URL and let me know if it helps.

http://www.howtogeek.com/howto/windows-vista/disable-user-account-control-uac-the-easy-way-on-windows-vista/

Collapse -

Well jswin, i didnt try that one on this machine

by titomba In reply to Vista/7 Specific

But the darn thing began working again today, how? dont ask me folks, it just decided to play nice, and now detects the printer, and i havent moved anything, i swear!

Now the problem goes to another vista machine, this one is really confusing me, i made the machine to work in the same workgroup, its wirelessly connected to the router, it has internet, but cant see any device, i made the network a workplace network, in the hopes to indicate vista that this network is safe to connect to. Printer share is enabled as well.

The catch here, is that the darn thingie, doesnt see any device aside from itself and the UPnP devices like the cams that are also wirelessly connected.

And to make things worse, the dialogue says, that the connection failed, but when i remote access the server, oh surprise!, it can see the machine that was trying to establish a printer connection.

Im really really considering the chance of changing the 2003 server as the printer server, and instead getting one of those wireless printer servers attached straight to the printer.

However, i am entering in doubt, it happened to me with a TS-s402 from trendnet, it happened that only few very few people could connect to the printer. And from those, very few could print the very next day, or they sent the print order, and the thing didnt even react to the request.

Of course people began spitting fire, so i dont know how much of a good idea would be to migrate to a wireless printer server.

One thing i know, im sick of these multiplatform issues, i mean it!

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums