Question

Locked

Vista UAC - no elevation prompts

By ellie_tville ·
I bought a new pc a few months ago and it came with vista installed. I have no experience of it and I am having real problems with the UAC, so much so that I have had to disable it just to be able to do anything! I would really rather not have this disabled as I can see it's uses..

Anyway, when I try to save a file to the computer (downloads folder, not C drive or anything) I do not get a prompt, Vista behaves as though it is saving the file, but when I go to locate the file so I can view it or install it - the file is not there. If I search for the file name - it is just not there. This is happening with .pps files and .exe files and .zip files. When I disable the UAC then it works fine!
I am on Vista home premium and would love to know what is going wrong! The pc is an acer if that makes any difference...

Thanks Ellie

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

I've seen this happen before . . .

by OldER Mycroft In reply to Vista UAC - no elevation ...

There is a very strong chance that the 'missing' files are actually intact and on your hard drive, just not where you expect them to be.

The search facility within Vista, which you'd be using when you can't 'find' your files, is rather selective in how thoroughly it searches.

It takes the stance that if the user is searching for some file, the file won't be in the user's own directory, because the user would have looked there first.

Try looking in the directory tree, under your user ID.

Collapse -

Thanks - a few questions though...

by ElaT In reply to I've seen this happen bef ...

The profile I have created is set as an administrator. When I go to save files I am saving them to elliet\downloads under my user profile. When I browse to this location they are not there. I have then tried searching using the search under start and it comes up with no file. I deliberately placed the files in this folder so I could easily find them - but they are just not there - sorry if I'm being a bit daft!

Ellie

Collapse -

YOU are not being daft - Vista is!

by OldER Mycroft In reply to Thanks - a few questions ...

My experience of Vista is strictly limited to the number of sad users I have had work from, all of whom have suffered at the hands of this abominable operating system. [Rant Over!]

I'm afraid my prior reply is about as far as I can delve into your present predicament - my Vista 'expertise' is sketchy at best.

What I CAN tell you is that whatever legacy habits you have, left-over from XP, will mostly not work in Vista.

I set up a Vista machine for a friend, installing WinAmp and filling it with mp3 tracks from his old XP system. I installed as I would have done for XP but when I started WinAmp in Vista, WinAmp couldn't 'see' ANY of the mp3's.

I remember sitting practically all night long trying to figure out why the file path was invisible to the system, when it was clearly THERE - I could see it and enter it and add /delete within it.

The answer was to 'allow' Vista to determine where the mp3 files were placed: I think the secret is (wait for it) you have to let Vista be involved in the creation of the DIRECTORY, then the directory is visible to the system.

If you created the directory within a file-manager like 2xExplorer or Opus or whatever, Vista will go through the process of 'saving' to that file, but as Tony Hopkinson put it in his Post, it's ALL A BLUFF.

For some unknown reason, Vista is set up to be spoon-fed with information (and to spoon-feed information back to the user) - so if you have ANY prior computer experience, using the techniques that previously were acceptable, causes major problems within the Vista environment.

Collapse -

Sounds like Virtualisation is kicking in

by Tony Hopkinson In reply to Vista UAC - no elevation ...

Save something to a file name you figure will be unique and do a search.

If this is happening Vista doesn't thing wahtever user you are logged on as is authorised.

Quickest way to fix is probably to login in as admin and create a new one.

PS virtualisation fools applications into believing they have saved a file.
So a normal user can't save to root, Program Files for instance. Visita creates a subd directory of the same name underneath one named for the user.
Don't see why it should be kicking in, in your circumstances unless your user profile is broke though.

Collapse -

thanks, but...

by ElaT In reply to Sounds like Virtualisatio ...

I just double-checked and my account is definitely an administrator (with a password) in the user accounts page it says that I should be asked for my password when trying to make any changes but this has never happened!
I have been trying to save the files under my username into the downloads folder - surely I should be able to save files to there and then be able to find them again? Am I missing something obvious?!

Thanks for your help!

Ellie

Collapse -

Just a thought, but.....

by ThumbsUp2 In reply to thanks, but...

..... what are you using to download? IE, Firefox, other? On occation, Firefox has fooled me as to where it put something I downloaded.

Collapse -

Using IE

by ElaT In reply to Just a thought, but.....

Hi Thumbs up - I'm using Internet Explorer.
I think it must be linked to UAC as when I disbale that then everything magically works! However I don't feel it's ideal to have it disabled all the time.

Collapse -

Have you tried what I posted above ? Try this . . .

by OldER Mycroft In reply to Using IE

http://techrepublic.com.com/5208-7343-0.html?forumID=101&threadID=247152&messageID=2379614

If you created the directory yourself it will cause what you describe.

Collapse -

pc was pre-installed but....

by ElaT In reply to Have you tried what I pos ...

Hi Old Mycroft, I did read your post but at first glance I didn't think it was relevant as this is a totally new computer that came pre-installed with Vista. However, I've just had another look and realised that I did copy some of our old files across, so possibly this is the cause of the issue!
I'm going to have another poke around tonight. It's just a nuisance that you have to reboot each time you make a change to the blooming UAC settings! I will post back once I have had another play.

Thanks for all the help
Ellie

Collapse -

If the files you copied across, included a DIRECTORY...

by OldER Mycroft In reply to pc was pre-installed but. ...

THAT is your problem.

Vista won't 'see' your directory, even although it does exist.

I know it sounds stupid - but that's it!

Back to Hardware Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums