Vista Wireless

By mmckinley ·
I have a 3com wireless switch which manages my 48 APs. When a student connects to the wireless network they are redirected to a page where they type in a username and password and authenticate against our radius server. After authenticateing they are directed to their home page. When a student first connects he/she gets the message press continue or close this page because our certificate is self signed. If you click continue it works fine in XP you are redirected to the authentication page. In Vista it just hangs there forever at the page with the certificate error. Has anybody heard of this? Any help would be great. I've tried everyting and I can't find anything on the web about this.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -


by retro77 In reply to Vista Wireless

Do you also get the same issue on WinXP clients running IE7? I think this is an IE7 deal. I get the same "error" information page when I log into my Linksys router.

You might be able to add it to the trusted sites under Tools|Internet Options|Security tab.

Collapse -

Try this

by uppulurivasu In reply to Vista Wireless

Hi Friend,

There are 2 issues which should be looked on
1) Vista Firewall
2) IE 7

In Windows Vista microsoft has implemented a 2 way firewall i.e. it checks both inbound and outbound traffic. Please disable it and see.

In IE7, disable the popup blocker and phishing filter with vista firewall down.

Collapse -

Same Thing

by bhibbitts In reply to Vista Wireless

I have a WXR100 AND WX1200 with around 10 AP's between them and this has been the most frustrating thing I've seen. I can get MAX, XP, 2000, even 98 to work but Vista just sits and there and comes back to the diagnose screen after trying to connect. The strange thing is Vista on a AMD chipset works great but Intel sucks. We are a university and students are coming in left and right with Vista but we have had no luck. We are also using the Web-portal with username and passwords for 3Com. I have talked with 3Com and they told me to roll back the driver or talk to Intel. I have searched all over and tried all kinds of things to no avail.

Collapse -

Just came across this

by bhibbitts In reply to Vista Wireless

Wireless Switch - How to use Certificate Services Web enrollment pages together with Windows Vista

Problem: How to use Certificate Services Web enrollment pages together with Windows Vista

Problem: Cannot import cert certificate to Vista machine

Problem: Unsuccessful together with a "Downloading ActiveX control" message

Problem: Unsuccessful together with a message that states that the Web pages must be updated

Fact: Vista

Fact: CERT

Fact: Certificate

Fact: Wireless LAN Switches and Controllers

Fact: Wireless LAN Switch WX1200

Fact: Wireless LAN Controller WX4400

Fact: Wireless LAN Controller WX2200

Fact: Wireless LAN Switch WXR100

Fact: Wireless LAN Managed Access Point 2750

Fact: Wireless LAN Managed Access Point 3750

Cause: The Windows Server 2003 Certificate Services Web enrollment functionality relies on an ActiveX control that is named Xenroll. This ActiveX control is available in Microsoft Windows 2000 and in later versions of Windows. However, Xenroll has been deprecated in Windows Vista. The sample certificate enrollment Web pages that are included with the original release version of Microsoft Windows Server 2003, with Windows Server 2003 Service Pack 1 (SP1), and with Windows Server 2003 Service Pack 2 (SP2) are not designed to handle the change in how Windows Vista performs Web-based certificate enrollment operations.

Fix: Please follow the Microsoft guidelines Article 922706 below :

Collapse -

WX2200 with Vista

by tinofec In reply to Just came across this

Thanks for the post.
I had the same issue with Vista as well. I guess my best bet is to upgrade the firmware to 6 instead

3Com = WX2200 version 4x
3Com = AP3750 Accespoint.

Collapse -

Same problem here

by whirrr In reply to Vista Wireless

I'm running a WX1200. Vista wifi works ok out at my 9 remote branches but not at all here at the Main branch (where the WX1200 is). All of the APs are identical (3com). The only difference is that remote branches have a router between the APs and the WX1200 (of course). We redirect the initial html request to a consent (AUP) page, but we aren't doing anything with certificates.

Collapse -

Fix available!

by jt In reply to Vista Wireless

We were experiencing the same issue with Windows Vista notebooks not being able to display the web portal page. 3Com has made available firmware version 6 for the WX1200 controller which solves this problem. After updating our WX1200's to version 6 firmware, Windows Vista computers connect fine.


Collapse -

Possible SSL version used during https

by chrisaguirre In reply to Fix available!

i had a similar issue pop after upgrading the software on my wireless controller but revers. laptops w/ IE7 worked but IE6 didn't. it turned out to be the SSL version. Check Internet Option / Advanced properties and compare SSL settings. you may need 2 or 3 depending on what your web auth requires.

Related Discussions

Related Forums