Question

Locked

Vista won't bring up log-on screen after hibernation

By Healer ·
My Vista Home Basic computer, a desktop which didn't have log-on screen before and the problem has been bypassed by bringing in secure log-on won't bring up a log-on screen at all when the computer is restarted after being hibernated. The computer has got SP1 installed. My the other computer which is a laptop and also has Vista Home Basic installed does bring up a log-on screen after hibernation. Is there a problem with the desktop?

This conversation is currently closed to new comments.

19 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

How to enable User Secure Login on Windows Vista

Most business environments "require" you to press the key combination of CTRL + ALT + DELETE prior to the log on prompt (the username, password and domain box). This is supposed to enhance login security to verify the authenticity of the login box (so that no other malicious software makes a similar box).

These steps will show you how to enable this functionality on Windows XP Home Edition and Windows Vista Home Premium. This may work on Windows Vista Home Basic and/or Windows XP Media Center Edition.

For Windows Vista Business, Windows XP Professional, Windows Vista Ultimate, these instructions may or may not work, I haven't tested them out, but you can likely enable it via the Control Panel applet or by using Group Policy Editor.

Windows XP Home Edition:

1. Make sure you are running an administrative account.
2. Open Control Panel.
3. Navigate to the User Accounts panel.
4. Click on "Change the way users log on or off".
5. Uncheck the box labelled "Use the Welcome Screen".
6. Click Apply Options, and close the window.
7. Press the WindowsKey + R (or click Start > Run)
8. Type in control userpasswords2. This is a rather unknown command.
9. Click on the Advanced tab.
10. Check the box that is labelled "Require users to press Ctrl+Alt+Delete"
11. If you wish, take a look at the other settings, but don't do anything that will annoy other users, compromise system security, or lock yourself out of your PC!
12. Click OK when done.
13. Restart your computer (or log off).

From now on, you will have to press Ctrl+Alt+Delete to access the login box and you have to type your username and password (and select domain if necessary) to log in.

Windows Vista Home Premium:

1. Make sure you are running an Administrative account.
2. Click Start.
3. In the Start Search box, type in control userpasswords2.
4. Click Continue in the User Account Control prompt. (The UAC is excellent by the way, I love it!)
5. Click on the Advanced tab.
6. Check the box that is labelled "Require users to press Ctrl+Alt+Delete"
7. If you wish, take a look at the other settings, but don't do anything that will annoy other users, compromise system security, or lock yourself out of your PC!
8. Click OK when done.
9. Restart your computer (or log off).

From now on, you will have to press Ctrl+Alt+Delete to get to the Welcome Screen to type your password in to log in.

Note that in both Windows XP and Windows Vista, this also affects when you Lock Computer/Switch User. You must press Ctrl+Alt+Delete in the Unlock Computer dialog also.

Hope this helps you.

Collapse -

User Secure Logon already enabled but fails after hibernation

by Healer In reply to How to enable User Secure ...

The computer has aleady had the secure logon enabled as you said and work seemingly all right thanks to the people in response to my earlier question http://techrepublic.com.com/5208-6230-0.html?forumID=101&threadID=307117&tag=nl.rCOMBINED. However, the computer when restarted after hibernation would behave like no logon required at all not to mention the secured logon after the computer has been put into hibernation but go straight to the desktop in this case.

Collapse -

Have you enabled autologon,

by Jacky Howe In reply to Vista won't bring up log- ...

if you have enabled autologon disable it and see if that clears it up.

In the Search box, type control userpasswords2, and then press ENTER. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Click the Users must enter a user name and password to use this computer check box, and then click Apply.

In the User Accounts dialog box, click OK.

After you restart your computer you should have to provide a password.

Collapse -

You can also

by Jacky Howe In reply to Have you enabled autologo ...

password protect the screensaver.

Have you modified the power savings?

Collapse -

screensaver and power-saving in default mode

by Healer In reply to You can also

As far as power-savings and screensaver are concerned, I left them all in default mode. The power plan is balanced and the screen saver is Windows Logo and wait 10 minutes.

Collapse -

autologon not enabled

by Healer In reply to Have you enabled autologo ...

Secure logon had been enabled for some time and I expect that should apply when the system restarts after hibernation.

Collapse -

Try this

by Jacky Howe In reply to Have you enabled autologo ...

Check this Registry Key to see if any of the users have been listed in there.

Press the Winkey + r and type regedt32 and then press ENTER.

The following registry key determines whether a user account name is explicitly filtered from the Windows logon screen.
Collapse this tableExpand this table
Registry key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList
Value name UserAccountName
Type DWORD32
Value data 0 = Does not appear on the Windows logon screen
Any value larger than 0 = Appears on the Windows logon screen

http://support.microsoft.com/kb/942956

Collapse -

No SpecialAccounts found

by Healer In reply to Try this

I have checked HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\ in the registry but there is no SpecialAccounts.

Collapse -

Something else to try

by Jacky Howe In reply to No SpecialAccounts found

Press the Winkey + r and type regedt32 and click OK.

Navigate to the following registry key from your left hand pane

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Right click and create a DWORD (32-bit) Value in right hand pane named HideFastUserSwitching

Set the Value data for HideFastUserSwitching to 1

Close the Registry Editor.

Press the Winkey + r and type control userpasswords2, and then press ENTER.

If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Click the Advanced tab, <b>UN</b>select the Require users to press Ctrl+Alt+Delete check box, and then click OK.

Restart the System and see if you have the welcome screen.

Collapse -

Previous problem is back if secure logon not required

by Healer In reply to Something else to try

The old problem has come back after I unselected the Require users to press Ctrl+Alt+Delete check box. The logon screen is completely missing so I have to put the requirement back.

Do you think I need to reinstall the computer to get everything back to normal?

Back to Windows Forum
19 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums