Question

  • Creator
    Topic
  • #2224786

    Vista won’t recognize USB external hard drives that work fine in XP

    Locked

    by rgsemail ·

    I have 2
    Ezquest/Maxtor 500gb usb external drives I was using on my Dell machine running XP.
    I got a new Vista (Ultimate) machine and, although it recognizes
    the hardware
    on both drives (& says they are “working properly” and
    enabled), it says the drives are “unreadable”; it does not
    recognize them in My Computer.
    I tried to partition the drive thru control panel but there is a
    red “+” sign
    on the drive icon for the Ezquest and nothing happens when I click it.
    (jut options for properties and help).
    (I did the original NTFS partitioning on the XP computer). I reformatted under XP (where they still work fine and still Vista won’t accept them.

    Thanks for any help.
    rgs92g@gmail.com

All Answers

  • Author
    Replies
    • #2634736

      Clarifications

      by rgsemail ·

      In reply to Vista won’t recognize USB external hard drives that work fine in XP

      Clarifications

    • #2634708

      Did you install drivers in XP for these USB Drives?…

      by older mycroft ·

      In reply to Vista won’t recognize USB external hard drives that work fine in XP

      If so, they won’t work under Vista. You’ll need to download Vista-specific drivers.

      If this is not the case, do your USB ports on Vista work with anything else? Check in Device Manager for errors on the USB ports.

    • #2624050

      fix for problem i think. Had same problem with USB drives and VISTA

      by satpats ·

      In reply to Vista won’t recognize USB external hard drives that work fine in XP

      I had this same problem. After 2 days of searching found info that may help.
      info at:
      http://tim.mackey.ie/VistaDriverProblemsFormacUSBHardDrive.aspx

      Basic points are some bug in Vista. You have to delete some file and presto it should work.

      Apparently there is some bug with Vista where you can get a corrupt driver cache file and if you delete it then it will solve all these problems.
      The culprit file is called INFCACHE.1 and it’s located in c:\windows\inf. I discovered this on a newsgroup post. This is the relevant parts:

      “The solution to this annoying problem (I had it on one PC), seems to be to locate and delete the file INFCACHE.1, which may be corrupted and causing the problem. To delete this file, you will first have to modify its permissions so the users group can access it (right-click on the file->Properties->Security). INFCACHE.1 file. It’s located at C:\Windows\inf (scroll down to the file). (Note: to see INFCACHE.1, you must set Windows Explorer to display hidden and system files)

      When modify these system files, i usually find i have to take ownership first for my own user account, then add myself to the permissions with full control. then you can delete it, or rename it to X_INFCACHE.1, etc.”

      Hope it works.

    • #2909688

      Don’t forget to set your SHARE option!

      by hebrewplace ·

      In reply to Vista won’t recognize USB external hard drives that work fine in XP

      Hi,
      This exact scenario happened to me and I emailed tech support after scouring knowledge base – NO HELP!
      Suddenly I wondered if I needed to set the device to share on the XP computer before the Vista computer would see it.
      Yep – that was it!
      No one knew from the manufacturer or in their FAQ!
      Hope this is your solution, too.
      Sarah

      • #2909682

        Thanks :)

        by rob miners ·

        In reply to Don’t forget to set your SHARE option!

        for that tip Sarah. If you don’t mind we can test it on the next Poster that has that particular problem. 😉

        Sharing a Drive has other benefits as well. 😉

        Rob

Viewing 3 reply threads