By Triathlete1981 ·
We're using VNC to remote into a computer. The service needs to be started. The VNC viewer works fine. But the computer is rebooted every morning and occasionally during the day. When it gets rebooted, the VNC service doesn't restart, and we can't access the computer.

The computer is Windows 98, connected to an expensive production machine so can't be upgraded. No issues so far with the computer being 98 and remoting in. And no issue with the fact that it's connected to the production machine. Just the issue with the service not starting.

The IP address is static and there is no problem getting network access, even after boot.

Any suggestions?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Have you ...

by PSer In reply to VNC

Checked HK_L_M\Software\Microsoft\Windows\CurrentVersion\Run > to verify that a reference to VNC is there? If not there should be. Or, you could put a shortcut to the .exe in the "Startup" directory. That way it will start up everytime the system does.

What v. of VNC are you using?

Collapse -

we are using vnc free...

by Triathlete1981 In reply to Have you ...

there is not a reference to VNC in that location. can i safely put one there? i've never felt comfortable editing the registry.

how would i put a shortcut in the Startup directory? Is that done through the Registry or done somewhere else? And what would the shortcut say?

Collapse -


by PSer In reply to we are using vnc free...

The registry key I pointed you to is the location of programs that load during Windows 'Startup'. Don't manually put anything regarding VNC in there.

You may want to re-install and see if the install process 'asks' you if you want it to start on boot up ... yes you do. You could also do the same thing in the properties of the viewer but not knowing what version, not exactly sure where to tell you to look.

The shortcut will be a fast and nasty. Simply right click and hold the exe, drag your curser to Start>Programs>Startup let go of the mouse and you will be prompted to create a shortcut, copy, move ... the shortcut should work fine for you. There are other ways to get 'stuff' into the Startup directory but like I said ... fast and nasty! BTW: the 'Startup' directory is self explanatory ... right?

Let me know how it goes ... I'll be checking back to make sure you get it working the way you want it to.

Collapse -


by Triathlete1981 In reply to Registry

I didn't do a registry edit. I dragged the Start VNC Service icon into the Startup directory as you said. That worked, and the service now starts with the other programs that start automatically on boot.

Thank you.

Collapse -

You bet!

by PSer In reply to registry

Glad you got it working!

Take care!

Collapse -


by ctmoore1998 In reply to VNC

Copy the VNC server icon to the startup folder, that way everytime the workstation is started the VNC server will be restarted at the same time

Collapse -

Start-up folder only works

by 1bn0 In reply to VNC

if a user logs in.
It also only works for the user profile it is created under. To work for all users you need to move it to the startup folder under "All Users"

What VNC are you using? Where did you get it.

We currently use WinVNC 3.3.9. It is an older version and I'm not sure where you can get it. It has a menu item after installation to "install WinVNC as a sevice". It also has a menu item "Install Service Helper". I'm not sure what that one does but it gets the icon to display in the system tray for the odd system it does not show up on by default.

There are many different implementations of the VNC protocol. If you can identify what Software you have installed you can get better responses.

Related Discussions

Related Forums