Question

Locked

VNC will not connect with DNS name

By cameron.p ·
I was wondering if anyone has a fix for this.
I am running Ultra VNC on a clients computer and I can connect using his DNS name but then when I go back in after using it the same day, it will sometimes not work. I can use his ip and connect but with the dns name it fails to connect. I am using Dyndns.org for my name server. If I try the next day, everything is fine again.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

A Few Questions

by rkuhn In reply to VNC will not connect with ...

Are we to assume that this client has a dynamic IP address and you're using DynDNS in order to connect?

If so, start exploring why the DynDNS client software isn't updating the client's dynamic IP address in a timely manner.

For example, is it set to start up when Windows starts up? Is it set as a service running in the background but only under a certain account? Is someone killing the service in the background?

Assuming your using DynDNS in order to connect to a dynamic IP address, focus on the client software and why it isn't updating regularly.

Collapse -

ip is changing

by cameron.p In reply to VNC will not connect with ...

Thanks for your reply. Actually, the ip is being updated and when I check the info on dyndns.org, it is correct. This is what has me baffled. By all respects, the name should work. The DNS updater starts at boot and is left on all the time. I also try to force an update with the same results. IP works but name does not. I also have this problem with my own dns name and I find that once it does not work, it will not start working again until the next day. I am trying to use single click for clients now and if the name does not work then I am out of luck. So, I need to figure this one out.

Collapse -

Network Issues?

by rkuhn In reply to ip is changing

Are there any proxies between you and the client?

Have you tried the old tried and true ipconfig /flushdns, flushed the ARP, etc?

Collapse -

proxy

by cameron.p In reply to Network Issues?

I have not tried the flush yet. Networking was never my strong point. I am more of a hardware tech. I do not think there is a proxy server. It is a 2 pc to router to dsl modem system. No server.

Collapse -

Still Think It's a DNS Issue

by rkuhn In reply to proxy

As you're probably well aware of, DNS is translating a name to an IP address. Since the IP address always works but the name is hit and miss, I'd continue down that troubleshooting route.

Have you tried doing a tracert with the name and then with the IP address at a time when the name isn't working?

Here's a resource on TR that might help:

http://downloads.techrepublic.com.com/download.aspx?&kw=dns&docid=172362

Unfortunately, you need Visio to read it.

Collapse -

will check

by cameron.p In reply to Still Think It's a DNS Is ...

Thanks for your help Rick. I am now waiting for the problem to happen again. Just like the car to the mechanic, I am not having any more trouble at the moment. I think that the info you have given me will help me narrow it down though.

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Forums