General discussion

Locked

W2003 multihomed

By NateH ·
Hi all,

I set up a Win2003 server with 2 NIC cards. NIC1 is set with a static IP (192.168.1.4) and connects to the router which connects to the internet. The other NIC2 is also set with a static IP (192.168.2.1), connects to the internal network.

I have 3 WinXP machines attached to the internal network.

I am trying to set up the server to provide DHCP for the internal network , but when I look at the DHCP menu, I can't get the internal IP address NIC to show up as an option. It only shows me the NIC1 to set up DHCP.

Any notions why I can't see NIC2 as an option?


thanks

Nate

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to W2003 multihomed

install DHCP services, authorize DHCP, then define a scope. Activate the scope. create reservations for any computers with static IP addresses. enable options for DNS servers, WINS servers [if you have em], Time Servers [again if you have em] and routers etc.

Collapse -

by CG IT In reply to

note: This suggestion isn't really a part of your problem with DHCP but just to ensure others on the LAN are getting correct info, I suggest you check your DNS A records. you should have an A record that shows your DHCP server name to IP address resolution and if your have reverse lookup a PTR record for IP to name resolution.

Collapse -

by smight In reply to W2003 multihomed

I think I figured out the issue. I setup a lab machine with 2 NICs just to see what was going on.

In the DHCP manager, when you have an authorized server displayed, the DHCP manager uses DNS to do forward and reverse lookups on the name of that server and it shows you the ip address of the DNS records. I adjusted the DNS records on my lab computer to get the display to change to the other IP address. You don't have to do this though becuase the display is irrelevant.

What you want to do is right click on the server and choose properties. Go over to the advanced tab and click the bindings button. Here you have the option of unbinding the DHCP service to the first IP and binding it to the second. This tells DHCP to service requests on the specific IP address you want.

I tested this with a DHCP client and when I did ipconfig /all to see what my info was, it showed the DHCP server which gave it an IP address as the second IP and not the first. I am pretty sure this will do the trick for you.


Hope this helps,
Chris Britt

Collapse -

by NateH In reply to

Poster rated this answer.

Collapse -

by NateH In reply to W2003 multihomed

This question was closed by the author

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums