General discussion

Locked

W98 LAN - one way slow connection

By jj.vergier ·
Hello,
I have been happily using a 2machines (Celeron 400 and PIII 750) W98SE network at home for some years.

Recently, data tranfer Celeron 400 -> PIII is very slow.(Copies 2 Mbytes in 1 minute, Word 2000 saves 2Mbytes in 3 minutes !). The other way (PIII -> Celeron 400 )works fine.

My switch is 100base-Tx, network adapters accordingly. I changed the switch recently, but the problem existed before that.

I couldn't figure this one out.

Thanks for your help.

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Chris910 In reply to W98 LAN - one way slow co ...

Could it be your virus scanning software?

Try temporarily disabling your scanning software then trying your file move.

Collapse -

by jj.vergier In reply to

I tried this first thing. Unhappily with no result.

Thanks.

Collapse -

by aquaris In reply to W98 LAN - one way slow co ...

1- check your wiring for any wear and tear....

2- try using a different port on the Hub..

3- get an estimate of ping response...either way..

(ping each other and see...whats the response differential if any)

4- is your Celeron....gone generally slow...with other programs too...

then may be it needs....say more Ram / defragmentation...etc..etc....

hope it helps.

Collapse -

by jj.vergier In reply to

Many thanks for all these tips ... which I had tried.

Ping is 1ms or "less than 10ms" either way, Celeron saves fine on local drives... mystery remains.

Collapse -

by wharb In reply to W98 LAN - one way slow co ...

For the Celeron 400:
Try "kicking" out your current network protocol stack by removing all of the protocols in your Network NeighborHood properties and removing the Microsoft Client for Networks network client. (must restart system after these steps)

Then re-install Microsoft Client for Networks client and make sure that it defaults to loading the TCP/IP protocol first. Then reconfigure, if needed, to the original settings that you had for that protocol. (Note. if are also using the NETBEUI protocol here make sure that is has the same level of priority in the order of install as the order of install in the PIII 750 PC.)

This should clear up any stack problems that may have developed in the past and restore your network transfer rate performance to what it used to be.

The "PC" SOFTWARE DOCTOR

Collapse -

by jj.vergier In reply to

TCP/IP is the only kind of protocol in my network.
Anyway I cleared it on Celeron, rebooted, reinstalled - no better.
I also reinstalled my network adapter driver and the whole network settings. Same result.
Thanks anyway for your extra time...

Collapse -

by Chris910 In reply to W98 LAN - one way slow co ...

The next thing to look at is the duplex settings on both computers and the switch.
--I am assuming that your switch is relativly new and does not have manual duplex settings.
--I am assuming that the network card in both computers are 100Mb. There are a few switches out there that have issues with mixing 10 Mb and 100Mb.
--Now check the speed/duplex settings on both cards and set them both to auto. (Here is how Right click Networkneiborhood-->properties--> highlight your network card in the window and select properties-->now this part is a little different for different network cards. select media type or duplex and speed and set them for auto.) (this should allow the network cards to correctly negotiate a speed and duplex setting.) Some switches have issues with duplex if the network card is hard coded for a speed and duplex.
--Power down both computers and power cycle your switch
--restart both computers and test your transfers again

Collapse -

by jj.vergier In reply to

Yes I had tried that too with no effect.

Thanks anyway !

Collapse -

by colin.r.bates In reply to W98 LAN - one way slow co ...

Have you tried deleting the winsock and winsock2 entries in the registry, I had a similar problem and found this worked. The winsocks dont get removed when removing tcp/ip protocols. I used add/remove windows progs to remove all communications and then went to the registry and deleted the winsocks. Then re-install and re-boot.

Collapse -

by jj.vergier In reply to

Didn't know about that issue. I tried it - but it didn't work.

Back to Windows Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums