General discussion


WARNING: terminal is not fully functional

By merishar ·
Been getting the message on SCO Openserver 5.0.7
I have begun the process of creating new users on the server. The shell that we use is /bin/csh. The user creation process seems fine. When the user logs in and types the list command ("l"), he gets this message "WARNING: terminal is not fully functional" prior to the command executing.
This took me a bit to figure out. We are using dosansi as the terminal type. In the .csh startup file there is a line containing the following (which I think sets it to dosansi):

Setenv TERM dosansi

I think we need this terminal type in the custom software that we run. The error described below also happens when you try to use the "man" command.

Any Help or suggestions would be greatfull.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Black Panther In reply to WARNING: terminal is not ...

Try this:-

When the user shells out get them to type

TERM=wy60; export TERM
echo $TERM ( to check that it is now wy60 )

try the l command or ls -l

maybe try the ls -l command in dosansi mode as well

Collapse -

by merishar In reply to

Poster rated this answer.
Tried the solution and it did not work
The first part of the instructions below does not work, so I could not try it. Something is wrong here. TERM=wy60 is not a valid command. Export is not a valid command.

TERM=wy60; export TERM

We run in dosansi mode. The ls command works. The ls -l command works. The l command works after the error message :WARNING: terminal is not fully functional".

Collapse -

by Black Panther In reply to WARNING: terminal is not ...

Can you try this?

Can you login to your server using Windows Hyperterminal, as the 'root' user.

If you get a prompt TERM=(ansi) then press enter and try the commands.

If you don't try the commands again.

Try echo $TERM

# echo $TERM

The TERM settings are in your /etc/termcap file.

You should be able to vi the file and search for the TERM types ie ansi, dosansi, wy60.

If it works as user 'root' through hyperterminal then try loggin in as a 'user' through hyperterminal.

Collapse -

by Nico Baggus In reply to WARNING: terminal is not ...

TERM=termtype is for bourne/korn/bash shels

csh uses setenv
Probably your term definition of dosansi is incomplete for a task you want to full fill from the termcap package.
Using vt100 might work as an alternative, although you might loose colors then.

you might use
setenv TERM vt100

just before any command that you want to be different from the system default.
Or put it in you .login or .chsrc file
if you want to have a different setting
the the other users.

Collapse -

by jdclyde In reply to WARNING: terminal is not ...

AT a council login, it should be scoansi as I recall.

Try that and see if that fixes it for you.

We also use vt100 as terminal type.

Collapse -

by jdclyde In reply to

So I see this is marked as answered.

What was the solution?

Would you mind processing the rest of the people who tried to help you out?


Back to Linux Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums