Question

Locked

Web Browsing issues on Server 2003

By seanseger ·
Okay this might get lengthy but I want to detail everything I've done.

We have a secondary site that we have just opened. We have a DSL connection to the internet with a site-to-site vpn connection for communication between the 2 sites. The server in our B site is running DHCP, DNS, and WINS (old service running in A site, will disable after everything is stabilized). All PCs at B use the DNS server at B and can surf the net, but the server itself cannot. I have tried having the server use the A-Site DNS and even the ISP DNS servers. No matter what, nslookup works, ping works (with sites that allow it), but web browsing doesn't. No other devices at A or B have a problem, just the B server. This has impacted Windows update and virus protection updates. I want to dcpromo the server, but don't dare until this is resolved.

B Server is an HP Proliant server running Server 2003 SP2, IP address 192.168.2.100, A server is HP Proliant running Server 2003 SBS, IP address 192.168.1.23.

ipconfig /all
Windows IP Configuration

Host Name . . . . . . . . . . . . : myhost
Primary Dns Suffix . . . . . . . : subdomain.domain.com
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : subdomain.domain.com
domain.com

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : HP NC326i PCIe Dual Port Gigabit Server A
dapter
Physical Address. . . . . . . . . : XX-XX-XX-XX-XX-XX
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.2.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.2.1
DNS Servers . . . . . . . . . . . : 192.168.2.100
192.168.1.23
Primary WINS Server . . . . . . . : 192.168.2.100
Secondary WINS Server . . . . . . : 192.168.1.23

Here are the things I've done to try to resolve this:
1) Tried different DNS servers
2) Reset Winsock (using netsh)
3) Reset TCP/IP stack (using netsh)
4) Reloaded NIC drivers
5) Installed Firefox 3.5 (to verify it wasn't an IE problem)
6) used ping -f -l to find the packet size that worked, and then set the MTU to match (1454, btw).
7) Turned DNS off and on
Turned DNS, DHCP, and WINS Server roles off and back on
9) Tried local administrator account and network account, neither works.

So that's it. I'm looking for a 10th and final way to fix this issue. If anyone has any ideas about where the problem is or what I can do to resolve it, I would love to hear back.
Thanks.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

ah really it's a good thing it can't browse the internet

by CG IT In reply to Web Browsing issues on Se ...

install Windows Server update service on the SBS box, have that deploy security updates to all workstations and servers on the network. This includes the secondary domain controller in site B.

Note: the secondary DC at site be should be a member of the SBS domain and replicate with the SBS DC. The secondary DC at site be can have the global catalog role and also do AD intergrated DNS updates.

Collapse -

I agree, but still...

by seanseger In reply to ah really it's a good th ...

I totally plan on implementing Windows Server update service. However, and this is my fault because I didn't clarify, but the internet access issue does affect more than just web surfing (although that's the easiest test). It also affects any programs that need to access the outside world. Most notably right now our virus protection program. But potentially something else down the road.

With this in mind, I really want to resolve this issue before I take the next step (dcpromo), but I need to take the next step so that I can move past implementing site B, and get back to fixing all the stuff my predecessors did wrong (such as WINS, the current lack of login scripts, non-standardized network drive letters, etc.), and get ready for Site C which I'm fairly positive will be happening.

So horrible grammar and interminable run-on sentences aside, I can work around the issue, but I'd rather fix the issue.

Collapse -

Just..

by Parsifal09 In reply to I agree, but still...

out of curiosity, what are you using for your gateway? I've seen something similar to what you describe that ended up being an issue with OS updates on a sonicwall. Also have you flushed and re-registered dns on any of the workstations at the B site to see if they suddenly develop an issue?

Collapse -

Interesting

by seanseger In reply to Just..

I am in fact using a Sonicwall TWZ190 (or something like that). It's the 190 with the wireless, although we don't use wireless on it. Hrm, the whole time I've been looking at it as a problem with the box, not a potential issue with the firewall.

I have flushed dns among many things with the workstations at B numerous times when we were having issues early on (before I discovered WINS was running at A), and none of them have a problem surfing the net.

I will check for OS updates for the 190 and update here if that resolves it.

Collapse -

Hopefully..

by Parsifal09 In reply to Interesting

that helps, I spent two hours at a client site scratching my head a couple weeks ago thinking I had lost my mind as everything else was in order and I'd gone over it a dozen times. After making sure you've updated sonicwall OS go through it's config with a fine tooth comb as it's possible that an entry that previously was not needed is now your culprit.

Collapse -

This is SBS network soooooo

by CG IT In reply to I agree, but still...

the problem your having is most likely a DNS issue.


If site B server only has itself and the SBS server listed as DNS servers, you might want to include site B ISP DNS servers as 3rd or 4th on the list of DNS servers to use which would then forward unresolved queries to the ISP DNS servers.

I'm assuming of course that site B internet connection is used for both web access and as a link to the primary site. While one might conclude that unresolved queries are automatically sent to root hint servers and the default gateway, unless you provide those DNS servers to site Bs server, it will not get access to the internet.

Collapse -

Firewall?

by pnoykalbo In reply to Web Browsing issues on Se ...

Do you have a firewall in your server? There's a built in firewall within the control panel. If it's on, turn this off. Click on the advance tab and make sure to uncheck everything (all network).

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums