General discussion

Locked

Weird BIOS detect/won't detect hard drive issue

By ragnarok-n-roll ·
I'm trying to fix my aunt's computer and it may have been infected with spyware or viruses. It is a Sony Vaio desktop (PCV-RX462DS) with a P4, RAMBUS and a Fujitsu drive and Windows Millenium (original install as far as I can tell). I already called Sony and they say they have no issues on record. The system BIOS does not have an autodetect feature.

When I went to go into safe mode, it locked up a few times, then the BIOS would not detect the drive. I used FDISK and it didn't detect the drive. So I figured the drive maybe died. I went back a few hours later and the drive detected on boot and I tried using a DOS boot disk to get in there and copy some data files off. Mere minutes later, it was no longer detected again! I waited a day, kept the side cover off, and had the drive connected only and outside the PC (not in the cage) and the same thing happened again! First it worked, then a few minutes later the drive spins up on boot, but you never get the head reading clicks and it won't detect!

So I bought a new drive (WD) and it detected. I used FDISk to format 2 partitions (one for OS to install, one for backup from old drive) and rebooted and formatted. Then the old drive wouldn't detect again, so I just went on with installing XP from the CD. That went past the copying files stage to the reboot, then it ran setup again...it seems that this brand new drive will not detect anymore in the BIOS!!!

I put the drives into another PC and they will not detect in there either. All I can think is there is something wrong with the IDE controller, the BIOS, or maybe the power supply? I'm also thinking it may be a heat issue on a component as the drive have detected several times and then stopped. The new WD drive was working fine for about 5 minutes before it "died".

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ragnarok-n-roll In reply to Weird BIOS detect/won't d ...

Some more info: The pre-fab drive cage is about 4 inches from the optical drive cage. I did notice that the IDE cable to the optical drives could be messing up the air flow from the front of the case to the back over the chipset and CPU- the way it is laid it is acting like a wall, so I will try to streamline the profile and see if that helps on my next attempt, along with leaving the drive outside the case.

I ultimately only want one drive, but had both in to try and transfer the files. I have already triple checked the jumpers, cables, BIOS IDE settings. Is this actually damaging the drive? Could it be a virus? Could the IDE controller be getting whacked somehow? What is the cause of BIOS not reading a drive, assuming it is not the cabling that is an issue? I mean it detects and I can DIR in DOS, and then within minutes, it's no longer detectable, and that pattern repeats in a totally different system. I'm a little sketchy when it comes to this level of knowledge and expertise. Thanx in advance for any help!

Collapse -

by TheChas In reply to Weird BIOS detect/won't d ...

I suspect that your root problem is the Fujitsu drive.

There is a known problem with at least 1 lot of Fujitsu drives and the ICs on the controller board.

The first thing to try, is to set up the WD drive as a single (no jumpers) and see if the BIOS will detect the drive without the Fujitsu connected.

If the BIOS detects the WD by itself, you can conclude that there is a problem with the controller on the Fujitsu.

At one time, Fujitsu had a link to a settlement option for owners of affected drives.
You could at least check and see if the drive you have is part of the suspect drives.

http://www.fcpa.fujitsu.com/products/hard-drives/hd-public-statment.html

http://www.hddclassactionsettlement.com/

Chas

Collapse -

by ragnarok-n-roll In reply to

The drive model (mpg3409) was listed as involved in this settlement! Thanx so much!

Since I last posted, here is what has happened:
Put WD drive back into cage and back into system.
installed Windows XP.
Configuring settings, installing apps, etc.

Works fine now! Guess that Fujitsu drive in the system really messed it up!

Collapse -

by ragnarok-n-roll In reply to Weird BIOS detect/won't d ...

Chas, thanx for the Fujitsu links & info!

I went to PCguide.com from a suggestion on another board and tried some steps, here is where I am at so far:
bios = latest
ps (fan works) wattage unknown; no label & no spec info in Sony book!
new WD jumper set for 2 drives in channel originally
removed optical drives ide cable
only kb/vga/power connected, with agp video & nic only cards
old drive no go, WD drive detects
remove WD drive, change old drive jumper to master
fdisk says no fixed drives present
loaded default/saved BIOS defaults & restarted
fdisk says no fixed drives present
change old drive jumper to cable select
fdisk says no fixed drives present
put old drive in another pc (40 wire and 80 wire cables tried)- nothing
removed old drive permanently from scenario; assumed dead, though it spins up
new WD drive, master jumper, only device on ide, optical ide disconnected
ok!
reconnect optical ide channel
ok!
fdisk delete old partitions (failed previous xp install), then fdisk /mbr just in case of virus (would this actually help?)

planning to install xp via cd, drive outside pc, cover off

Will keep you posted.

Collapse -

by ragnarok-n-roll In reply to Weird BIOS detect/won't d ...

This question was closed by the author

Back to Desktop Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums