Question

Weird network switch behaviour with Sky Q router

By skullmaggots ·
Hi,
I've been having a strange issue with my internet connection for about 5 months now. Over time I've thought the root cause of issue to be many things and have tried various different solutions none of which fix the problem.
 
So,  right now I bought a new unmanaged switch (NetGear 24port GS324P with 16 POE ports) which I've plugged into the Sky router ethernet port (tried both ports). I then have a number of wired devices around my house which are connected into a patch panel and them from the patch panel into the switch. 
 
I plugged in the ports from the patch panel one by one into my switch and the devices on the other end (UniFi Access Ports, Sky Man Box, Mini, TVs etc.) all booted up and got an IP address and connected fine to the internet. I then thought that was easy as previously things have been working intermittently and it must be my recent decision to change from a managed switch to an unmanaged one (as I read Sky Q doesn’t like managed switches)
 
After about 10 mins most of the devices dropped their connections, and some reconnected but with a much slow speed e.g. 2Mb/s. (Was 35 Mb/s before).

To diagnose the problem I connected my iMac directly by a Cat6 Ethernet cable into the switch (so patch panel and network ports in my house taken out). I then watched and saw the iMac get a link state light and then after about 8 secs and IP address (not sure why 8secs, why do long?). I then try a ping to google.com and all was good showing times of about 15ms for each ping and no failures. Then after about 2 mins the ping latency increases, and then pings start failing, with only 10% of the pings working.  Hmmm, strange.

So I took the Cat6 cable that connects my iMac to the switch and plugged it directly into the back of the Sky Router directly. Immediately the pings started working with a steady response time. I watched this for ages and it worked fine with no issues.

I then put the Cat6 cable back into the switch and the saw it connect, renew the IP address and the pings started to work and then after about 2 mins the pings slowed down and failed. I also checked a browser and the connection was occasionally working but mostly not, so this is not an issue with the ping itself.

I then disconnected the other devices in the same switch, leaving me only the cable from my iMac and the one form Sky Router. Low and behold the ping started working reliably - WTF!!!.

I then plug the devices back into the switch one by one and after I plug about 3 back
Thread display: Collapse - | Expand +

All Answers

Share your knowledge

Related Discussions

Related Forums