Question

Locked

weird winders update problem . . .

By Who Am I Really ·
- Friend brought me his ailing HP Media Center m8300f
- I said the only way to restore it is to order the recovery media from HP, as I don't have an OEM system builder copy of vista home prem.
and it's cheaper to pay HP the $42.00 than to go hunting for an OEM system builder disc.
- DBAN'd both 320GB HDDs in the unit and it ran with no problems for the 20+ hours for each HDD wipe
- installed via the recovery media
- all works fine
- removed the trialware of norton or mcbloat (don't recall it was quite a while ago) and installed MSE
- tried getting updates from winder update
- ran fine until close to the end of the batch of updates (I install updates individually never in bulk)
- last few updates hosed the system don't know which ones because the system wouldn't start
- system would boot to password and before fully loading the desktop, boom it shuts off
- every attempt to start the system only made things worse as it would shut off sooner until it wouldn't even display the login dialog before it shut down

- restored from the recovery partition
- second time around starting over from the recovery partition restore
- tested the disk with both SpinRite and Seatools (NPF)
- tested the RAM with the RAM Abuser from the windows online crash analysis page (NPF)
- MS is weird, they won't offer the SP until all updates are installed,
(why then are "all previous updates included in the SP if I can't have the SP from winders update until all previous updates are installed)
- anyhoo, while the system was rebuilding from the recovery partition, downloaded the network installers for both SP1 and SP2, since vista SPs don't have the previous SP included, both are required,
unlike XP or Win2K where the previous SPs aren't necessary, an RTM win2k can go directly to SP4, and an RTM XP can go directly to SP3
- got the SPs installed, and the system runs fine
- start doing the updates and boom, back to unexpected shutdowns again
this time I only had 2 updates done
- > - KB961501
- > - KB970238
- both dated 9/June/2009, which are the first updates offered from the first crash Tuesday following the May SP2 release

- I can't return the system without finishing the updates
- but I can't get it to update either
- restored it again and runs fine at SP2 and no post SP2 updates

- any ideas to what is bombing the system when I start updating, or what to do about it?

- it's currently running another disk test, (this time @L4 which is 20+hours / disk)

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

It seems that you are doing all the right things

by robo_dev In reply to weird winders update prob ...

When you get a tough-dog like this, it's probably a hardware problem that you don't expect, a buggy bios, or a bad driver.

Don't forget to look into BIOS updates for the motherboard, as well as making sure your hardware drivers are the latest and greatest.

You ARE running VISTA, so you're running naked thru barbed-wire there :)

On a Pc like that I would load up XP...it's less likely to have weird issues like this. I worked on a friend's Dell Vista laptop for hours....the symptom was that Windows updates stopped working. I loaded XP and it's been working great ever since.

Collapse -

Reponse To Answer

by Who Am I Really In reply to It seems that you are doi ...

that would be:
- Running naked through barbed razor wire, that's stretched over a 200 sq mile mine field that was planted in 10 foot high thistles and cacti all the while being chased by half starved bears, lions and tigers (ouch)

in all seriousness,
XP would be great,
except about 2 or 3 repairs ago, he took it to some shop and they installed XP and it didn't work right straight out of the box
so then he sent it to an "HP authorized repair center",
they did what they're trained to do:
- re-install the system from a recovery disc set and send it back out without checking anything else
that hosed all access to the XP partition
- no access to boot into XP nor any access from within Vista
- while looking at it (I have my methods) I could see that the XP install had hardly been used before it was sent in to the HP center

now it has come to me
I'd install XP and hunt down the drivers if it were mine, because I'm OK using XP
(read HP not supporting or supplying drivers for this system for anything but Vista)

plus, I've only released one XP system into the wild,
and that was to a friend who is more paranoid about security than I am,
so I said OK and rebuilt his system

now I get this thing;
funny thing is that on the first install, I got a long way through the 100+ updates before it bombed out almost made it to getting winupdate to offer the small SP1

this time I got SP1 & SP2 installed and no other updates
since it bombed out on the first post SP2 updates

Collapse -

Yep I'm in agreement with Robo here

by OH Smeg In reply to weird winders update prob ...

But I would add have you tried throwing the Ultimate Boot CD at this unit?

It's got a lot of Diagnostic Tools that just seem to work better than the M$ Offerings, it's also free. :0

http://sourceforge.net/projects/ubcd/

Col

Collapse -

"crash Tuesday"

by seanferd In reply to weird winders update prob ...

Thanks for that. :^0

Check to see if there is an update to Windows Update. You may need to have that installed first, even though nothing is indicating such directly (like with a message instead of crashy).

Collapse -

So it's something to do with SP1 or SP2 of Vista

by OH Smeg In reply to weird winders update prob ...

That's the obvious thing to accept. :0

funny thing is that on the first install, I got a long way through the 100+ updates before it bombed out almost made it to getting winupdate to offer the small SP1

this time I got SP1 & SP2 installed and no other updates
since it bombed out on the first post SP2 updates


So I suppose the obvious thing is what is the actual Hardware here?

It could be something to do with the Slipstreamed Recovery Disc being made with a Intel CPU System and this has a AMD CPU or vise versa. I remember that one of the Vista Service Packs had that problem supposedly and it was only supposed to affect AMD Systems but I had a Intel System hit by that Issue. Though now I can not remember which Service Pack it was.

See if anything here is of some help though I don't think it's likely.

http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/windows-explorer-crashes-after-installing-vista/5e045080-7e1e-4de4-978d-1c606063f312

Col

Collapse -

Reponse To Answer

by Who Am I Really In reply to So it's something to do w ...

there's no slipstream disc in use
neither is there a burned disc
it's a pressed Disc set: HP "for specific PC" branded recovery media
and I had to order it

here's the system spec page:
http://h10010.www1.hp.com/wwpc/ca/en/ho/WF06b/12132708-12133156-12133158-12133158-12133158-81574412-81574610.html

and here's the system support and drivers page:
http://h10025.www1.hp.com/ewfrf/wc/softwareCategory?product=3644702&lc=en&cc=us&dlc=en&lang=en&cc=us

and that's where the recovery media comes from also

I don't know which updates might have bombed the system the first time around
it bombed before either SP was installed

and it runs fine with the SPs installed
it's just a problem to update

anyhow, when the thing boots up, I'll try picking a different crapdate to install

I'm not seeing it as an explorer crash, it appears in the event viewer only as:
"Unexpected Shutdown"

(I'd offer y'all some +'s but the site just kicks me out to "page not found" when I try clicking a +)

Collapse -

The HP Recovery Set is the Slipstreamed Image

by OH Smeg In reply to weird winders update prob ...

HP makes them well back in the day any Off the Shelf System Maker made them and the problem according to M$ at least was that the Image was made on a CPU System different to the system that the Image was made for. So if it had a AMD CPU the Recovery Set should have been made on a system with a AMD CPU and if the system has a Intel CPU the Image needs to be made on a system with a Intel CPU.

Sorry but I don't buy that either but it was what M$ was pushing when the issue first came out. It was supposed to only affect HP units with AMD CPU's if I remember correctly but I had a Acer with a Intel CPU which was affected.

When I rang Acer and asked if they had a Known Issue with the Service Pack they insisted that I was attempting to install a Beta and I should wait for the Release Version. Didn't matter that it was the Windows Update Service that had downloaded and had failed the install or that the Finial Release of the Service Pack had just been released within the past 12 hours.

However you can try this but I'm not sure if it's going to be of any help. I can no longer find the script that we ran on Vista supplied by M$ to cure the CPU Issue that they had. Seems to have been removed about t he same time as Support for Vista ended.

Here are a few steps you may try:

Check and Ensure that your Windows Modules Installer Service (trustedinstaller.exe) is not disabled and stopped; but set to manual and started. This WMI Service enables installation, modification, and removal of WindowsUpdates.

Restart your computer and check Windows Update again.

Ensure that the following three updates are installed and do not show as failed: KB935509, KB938371, KB937287.

Check your hard disk for errors. Please also see this Checklist.

Disable your anti virus, firewall, anti-spyware and restart. Make sure these 3 are disabled on restart.

Run the System File Checker Tool. Open cmd and type sfc /scannowand then press ENTER.

Run the Windows Vista Memory Diagnostic Tool. Open Memory Diagnostics Tool. Click Restart Now and Check Problems. Your computer will restart and the diagnostic program will start. Note any reported errors. For more help, click KB947366.


Col

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Forums