Question

Locked

Western Digital 120gb hdd not recognized by windows

By claytoncmk ·
hi all,

i am using western digital 120gb external harddisk. when i connect it to my computer, there's a blue light at the side of the hdd showing that it is connected to the pc. but on my pc, it isn't registering on "my computer". when i look for it under "device manager" , i can locate it as " usb mass storage device ". having browsed through this forum itself, there're advices on re-mapping the drive under " disk management " . when i went there, the drive is not registered there. all i see is my com's built in hard disk, as well as it's partition.

any way to salvage this situation? really precious because all my files are stored inside the hard disk since my laptop has little space.

this incident happened after i got my hdd back from being passed around... hmm

help anyone? thanks in advance!

cheerios,
claytoncmk

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

changing drive letter

by butch_firefox In reply to Western Digital 120gb hdd ...

hello...have you tried already rechanging the drive letter of your external hard disk?just right click the my computer and you see the manage.click that and after that click the disk management and change the drive letter of oyu device.it might possible that it has the same drive letter from oyu internal storage device.just like flash drives.is detected but don't run....hope it helps..gud luck

Collapse -

Mmm... "precious files" & "passed around" ? ...

by OldER Mycroft In reply to Western Digital 120gb hdd ...

I think you may have already answered your own question.

I would suggest that you find out if it works in the last of the computers it was passed around to while it contained all these 'precious files' of yours.

Alternately have you tried all available USB ports?

Collapse -

Could be a couple of things here

by OH Smeg In reply to Western Digital 120gb hdd ...

The most common is that the Drive isn't removed through the Safely Remove Option in Windows.

While I don't think that's the problem here because it's not appearing in the Drive Manager. If the Partition Information gets Trashed you always get a Blank Drive showing in Drive Management and you are told that the unit needs Formatting do you wish to Proceed?

What I think has happened here is that the Drive has been dropped or knocked off a Table or something similar and it has destroyed the Drive inside the enclosure. To check this run the Drive Makers Testing Utility to check the function of the Drive. If this is the case you need to take it to a Data Recovery House to be Recovered if the Data is worth the cost of Recovery.

The other Nasty one is that it has been connected to a IBM T40 or newer NB that has a Separate Password Chip built onto the M'Board which has been enabled while the External Drive has been fitted and the Account Owners Data has been Made Private, This Locks out the Drive without doing any actual Damage. The only solution here is to plug it back into the same Model IBM and remove the Password. Naturally you can Format up the Drive again but you'll lose all your Data and it will not be possible to recover it.

You need to make sure what has happened here before proceeding anywhere along the line. When you plug it into the Computer does the Found New Hardware box pop up on the right hand bottom of the screen? If it does that means that the Enclosure is working sort of anyway.

Another possibility is that the Drive has been run non stop for a few days and the Electronics in the Enclosure have been damaged by heat. Hopefully it's just the USB to IDE interface involved and fitting the drive to another Enclosure will allow you to recover the Data. But if that's the case I wouldn't trust the Actual Drive for a Long Term Storage Solution.

Generally speaking when a Failure like this occurs it's better not to do anything as when you need to go to a Professional Recovery Organization the more that you have done now the more that the Recovery Costa and the less that can be recovered is.

But if you want to have a go but only if the drive Tests as OK with the Makers Testing Utility you can try one of these Data Recovery Programs.

http://tinyurl.com/273ay5

http://tinyurl.com/rmvrv

http://tinyurl.com/yvrsl

http://tinyurl.com/yyk8cm

http://tinyurl.com/382vm

http://tinyurl.com/ynwnel

http://tinyurl.com/nc4kx

http://tinyurl.com/2wox7l

http://tinyurl.com/374d8b

http://tinyurl.com/djw6u

http://tinyurl.com/f73se

http://tinyurl.com/8bd3f

http://tinyurl.com/afu2j

While the last 2 are from the same company they are very different products. Win Hex should only be considered foe use by someone who knows Hex Inside Out while Davory is a great cheap General Purpose Application.

Personally I prefer the On Track Option but it's anything but cheap. However because I use this type of software a lot it's paid for itself many times over by now, for a cheaper option Spin Rite from Gibson Research or Stella have both very good reputations by other TR members.

Not a complete list of what is available but some of the better ones none the less.

Col

Collapse -

hmm?

by claytoncmk In reply to Could be a couple of thin ...

when i run device manager, there is a yellow " ! " on the Filedisk under "Non plug and play drivers"

will this affect in any case?

the drive has been dropped once i think. hmm come to think of it. it shows up in windows when they said that a disk drive is detected. but just that it doesn't register in "my computers"

the data ligeguard diagnostic show this message " cable test :: read diagnostics sector error! "

any idea what this means?

and also, any way to recover it?

ty in advance (:

Collapse -

WD's error Codes for their Life Guard Software is located here

by OH Smeg In reply to hmm?

http://tinyurl.com/yp53gh

The Cable test means this

Failure during cable test. The cable is loose, broken, or not plugged in. Recheck your connections and replace the cable. Retest the drive.

The recommendation is to fix the Lead and retest the drive.

As the drive isn't appearing in the Device Manager I would think that there needs to be a Driver Installed to work this unit so if you no longer have the necessary driver download a copy from WD's download site here

http://tinyurl.com/v4q8

If none of this gets the drive readable again you need to contact one of WD's Data Recovery Partners if the drive is Under Guarantee by looking here

http://tinyurl.com/4lmj3r

If there is no Guarantee on the drive left you can take it anywhere for the Recovery but I must warn you it's not cheap. The last dead Drive that I had to take to a Recovery House cost 46K in AU$ to recover but that was the next day service on Important Data required for an Audit by the Tax Man. Most people don't consider their Data Worth the Cost of Recovery as they can replace it easily even though a lot of time may be required. Even the better Data Recovery Software that can be used on a working Drive isn't cheap you will be looking around the $1,200.00 Mark for this. Unless you look at something like the base Recovery Options like Davory which can recover Files by Type but not Name so you need to scan a drive for all files of 1 type and the Recovery Software will pickup all listings of that type and save them for you which is always to a different Drive to prevent Overwriting the Data. These Scans can run for a few minutes to days and can recover thousands of Files which may be complete or incomplete depending on how much they have been overwritten so there may not be anything useful recovered It's really a Suck It and See thing.

Col

Collapse -

The drive has been dropped once?

Well since it has been dropped then it will not show up (depending on what it was dropped on) on your computer, maybe because of damage to the arm. You could try this:

http://www.grc.com/sr/spinrite.htm

Please post back if you have more problems or questions.

Collapse -

hmmm... tried virtuallabs

by claytoncmk In reply to The drive has been droppe ...

they said that the drive has bad sectors or something. hmmm...

Collapse -

Now you tell us that piece of Important information

by OH Smeg In reply to hmmm... tried virtuallabs

OK the drive has been dropped while running and the Heads have come into contact with the Platters inside it.

If the Data is Important don't use the drive again take it to a Data Recovery House and pay them the requested amount of money and they will get what they can off the drive.

Of course where the Heads have hit the platters and damaged the Magnetic Material there is no possibility of getting anything off of there as the Material that is used to store Data is damaged on that part of the Drives Platters at least.

The heads will also have been damaged and could be dragging on the Platters in which case the possibility of recovering anything is very unlikely no matter how much money you are prepared to give them. The more that this drive has been run the less likely the chance of recovering Data is.

So as it has been dropped and the Data is supposedly Important you only have one option and that is to take it to a Data Recovery House and let them loose with it. If they tell you that they can do nothing then the Data is Lost. Only thing here is that you need to take this to a Data Recovery House who can read directly off the platters so they need to dismantle the drive in a Class 1 Clean Room remove the Platters and fit them to a device to read the Information directly off the Platter. If they can not do this type of Recovery they can not help you with this problem.

Col

Collapse -

A quick try

by Dumphrey In reply to Western Digital 120gb hdd ...

in device manager, choose show hidden devices. Under USB, find the listing for the disk, and delete it, this will force re-detection on the next insert. Plug the disk in, the new hardware wizard should appear. If not, as Smeg said, start looking at hardware...

Collapse -

Connect to IDE

by ozi Eagle In reply to Western Digital 120gb hdd ...

Hi,

If your computer is a desktop or tower, try removing the HDD from the USB enclosure, setting the jumpers as slave and connecting to an IDE port in the computer.

Herb

Back to Hardware Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums