western digital external hard drive

By Jorgezach ·
Hello! I have western digital external hard drive.
Due to my own fault for rushing through the process, I must have disconnected the drive before time.
This external drive is connected with a Y type cable, I am not sure if there is the possibility that I misconnected the whole thing.
The computer acknowledges the drive and the name.
But when I tried to read the 300Gbts of information nothing happens.
When looking into the drive properties it shows 0bytes available and 0 bytes used.
The red light comes on and flickers time to time and I can feel the drive motor running
It's like if it doesn't boot itself.
I would appreciate if someone could help.
Many thanks
Jorge jorgezach@sapo.pt

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Most likely if you disconnected the Y Cable

by OH Smeg Moderator In reply to western digital external ...

Before you had the Safely Remove notification you corrupted the Partition Tables. You can try running CHKDSK /R on the drive and it may repair the Partition Tables or you'll need some form of Data Recovery Software to rebuild the corrupt tables.

But first things first if you pulled the Y Cable out by the lead and not the plugs you should first try another Y Cable as you could have damaged the Y Cable and it's no longer making a Data Connection or one of the Power Connections. Y Cables only have the 1 plug with a Data Connection and both plugs have a Power Connection so you get a greater amperage to the External Drive. If the cable is damaged the drive isn't going to work.

Now for the nasty bit, if the data on the drive is Important that you need to recover and a replacement Y Cable doesn't do the trick you should send the drive to a Professional and pay them to recover your Data. If you mess with the drive unsuccessfully you run the risk of making a Professional Data Recovery much more expensive and far less likely to be able to recover 100% of your Important Data.

However if it would just be Nice to recover the data and you can afford to loose it all attack the drive with whatever recovery tools you like. You at worse will be wasting your time and effort and will loose everything but you just may recover what you need without costing you an arm and leg.


Collapse -

In regards to your drive, I went through something that may be similar!

by gadjet In reply to western digital external ...

First, experience shows, unplugging the usb cord before you "ask" is not okay. go to the icon to ask for disconnection first! Second and probably more applicable, you can not have more than one "big" drive hooked up by USB with the WD drives. The second drive will not be recognized. I was trying to use two 3TB drives. WD drives have a unresovled "issue", this is straight from the service of WD. I did something with mine, then I couldn't do anything with it. The computer would know it was there, but couldn't recognize it. Luckily it was fairly new, I ended up returning it to the store and got another, otherwise, you will probably have to go through WD service. It is amazing how much info you can lose in the process, bigger drives, more info, more loss! I'm still trying to recover and rebuild from other sources. These large drives are adding a whole new meaning to backing up. Originally, I was trying to back up one drive to another, I did not work!
Additionally, the data was totally unrecoverable, we couldn't get the drive back no matter what we tried! It was like a blank drive with no access!

Related Discussions

Related Forums