Question

Locked

What could cause a shared directory latency issue?

By tkleehamer ·
We have two shared directories that certain users are experiencing latency while navigating (explorer.exe does not respond for 2 or more minutes). The shared directories are located on a Windows Storage Server 2003 machine with several other shares (some even on the same partition) that have not had any latency issues. Users are connecting to the shares via an AD login script. One of the problem directories actually shows latency while logged into the server directly, not through a share. Oddly, with both problem directories, new users are the only ones who experience the latency. I have checked the directories for viruses, removed any shortcuts that were created within them, and defragged the directory. I even tried coping the dirctory thats acting up locally to another partition and the same issue is occuring. Furthermore, the RAID controller is reporting that everything is ok, so I don't think it could be a drive failing. Any other ideas of what is going on?

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Latency -

by joeyj In reply to What could cause a shared ...

Do the users have admin permissions on the workstation they are logged into? Also, check the privilages of the users on the shared resources (drive, and folder share permissions). Have you tried to log the users into another workstation to check the latency? Download Wireshark, and run it on the workstation the user is logged into, it may be able to help you find the offending packets.

Collapse -

Latency

by tkleehamer In reply to Latency -

Yes, domain users have local admin rights. Permissions are set correctly, when they get inside the folder everything works fine. Yes I have had the newer users log into another workstation and the same thing occurs even on a machine that works fine for the older users. I don't think WireShark is going to catch anything since the issue occurs locally as well.

Collapse -

Is your latency just while doing the initial view, or usage?

by jdclyde In reply to What could cause a shared ...

How many files are in the directory?

Are there hidden files in the directory?

An Indexing issue? If this is only new users that are effected, that would be my guess.

Collapse -

Initial view

by tkleehamer In reply to Is your latency just whil ...

The issue occurs when the folder is first opened. Once inside, navigating through the subfolders is no problem. However, if you go back to the top level, latency occurs again.

There are 6,425 files and 586 folders in the directory.

Not sure about hidden files, there aren't any directly inside but I'm not sure about inside the subfolders. Is there an easy way to tell without looking through the 586 folders?

It seems to only effect new AD users. Although, when I'm logged into the server directly as the admin, it happens to me on one of the two probelm directories. AD users who have been using the folder prior to the new users complaining, have no problem.

Collapse -

Initial view

by tkleehamer In reply to Is your latency just whil ...

If this is an indexing issue, what can I do to resolve it? The service is not started on the local machine but it is started on the server. If I turn that off will it cause other issues?

Thanks for your help.

Collapse -

Stop Server service

by Bapster In reply to Initial view

See if the problem goes away (even temporarily) if you at the cmd prompt you do a NET STOP SERVER, then a NET START SERVER?
Then retry the affected machines to see if helps, at all.

Collapse -

Server Service

by tkleehamer In reply to Stop Server service

Hm, I'll have to try this when no one's online, but will it really help when the issue occurs when connected to the server locally?

Collapse -

Strange...

by tkleehamer In reply to Is your latency just whil ...

Here's something else I just discovered. If I open the folder using a command prompt or a shortcut, it opens instantly.

Collapse -

From your prior post...

by cmiller5400 In reply to Strange...

It is a problem with windows explorer trying to gather information on EVERY file/folder that is in the root of the shared directory. When you click on it, windows explorer goes out and gets the attributes on all the files (size, type, attributes(such as read only, hidden, system) etc). The more files you have the longer it takes. Over a WAN connection it can be PAINFULLY S_L_O_W.

Collapse -

Gathering info...

by tkleehamer In reply to From your prior post...

This is what I though at first, but there are MUCH larger folders on the same server that do not cause this issue.

Back to Networks Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums