Question

Locked

Where do I point devices in a VLAN?

By devdevil85 ·
Scenario: 2 Vlans on a L3 3560

In VLAN1 I have the devices pointing to the L3 switch itself and they can communicate w/ devices on VLAN10 and get to the net.

In VLAN10 I have the devices pointing to VLAN10 itself and they, too, can communicate w/ devices on VLAN1, but they cannot get the net.

Why is that?

Here is my configuration thus far:

192.168.1.15 = Router
192.168.1.7 = L3 switch
192.168.10.1 = Vlan 10 Id
192.168.1.1 = DHCP Server

User Access Verification

Gateway of last resort is 192.168.1.15 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 192.168.1.15
C 192.168.10.0/23 is directly connected, Vlan10
C 192.168.0.0/23 is directly connected, Vlan1
Cisco_POE#

Current configuration : 2227 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco_POE
!
ip subnet-zero
ip routing
!
ip dhcp snooping vlan 1-10
ip dhcp snooping
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
ip dhcp snooping trust
!
interface FastEthernet0/2
ip dhcp snooping trust
!
interface FastEthernet0/3
ip dhcp snooping trust
!
interface FastEthernet0/4
ip dhcp snooping trust
!
interface FastEthernet0/5
ip dhcp snooping trust
!
interface FastEthernet0/6
ip dhcp snooping trust
!
interface FastEthernet0/7
ip dhcp snooping trust
!
interface FastEthernet0/8
ip dhcp snooping trust
!
interface FastEthernet0/9
ip dhcp snooping trust
!
interface FastEthernet0/10
ip dhcp snooping trust
!
interface FastEthernet0/11
ip dhcp snooping trust
!
interface FastEthernet0/12
ip dhcp snooping trust
!
interface FastEthernet0/13
ip dhcp snooping trust
!
interface FastEthernet0/14
ip dhcp snooping trust
!
interface FastEthernet0/15
ip dhcp snooping trust
!
interface FastEthernet0/16
ip dhcp snooping trust
!
interface FastEthernet0/17
ip dhcp snooping trust
!
interface FastEthernet0/18
ip dhcp snooping trust
!
interface FastEthernet0/19
ip dhcp snooping trust
!
interface FastEthernet0/20
ip dhcp snooping trust
!
interface FastEthernet0/21
ip dhcp snooping trust
!
interface FastEthernet0/22
description port on VLAN10
switchport access vlan 10
switchport mode access
ip dhcp snooping trust
!
interface FastEthernet0/23
ip dhcp snooping trust
!
interface FastEthernet0/24
ip dhcp snooping trust
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.7 255.255.254.0
!
interface Vlan10
ip address 192.168.10.1 255.255.254.0
ip helper-address 192.168.1.1
!
router rip
version 2
network 192.168.1.0
network 192.168.10.0
!
ip classless
ip default-network 192.168.1.0
ip route 0.0.0.0 0.0.0.0 192.168.1.15
ip http server
!
!
control-plane
!
!
end

It says 192.168.0.0 directly connected Vlan 1, but shouldn't it be 192.168.1.0 since it's the .1 subnet?

Please help!

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Gateway of last resort

by robo_dev In reply to Where do I point devices ...

not sure about "shouldn't it be 192.168.1.0 since it's the .1 subnet?"

The router will show what it sees...I think the 192.168.0.0 is the 'classless' way of summarizing the route with RIP version1????

can you ping the gateway of last resort from vlan10?

http://www.cisco.com/warp/public/473/50.shtml

....something to do with VLAN trunking or using the switchport mode trunk command?

Collapse -

I cannot ping GW of last resort on VLAN10

by devdevil85 In reply to Gateway of last resort

but I can ping it from VLAN1 which of course is why it's acting normal and functioning properly.

Sorry about the route summary thing. I see what you're saying.

But yeah I can't ping GW of last resort from any device on VLAN10.

Just so you know, I'm using a 3560 to basically add VLAN10 and to get the exact same situation for devices on VLAN10 as devices on VLAN1. I don't want to use an external router since it's L3 capable.

Collapse -

Yeah I only have (1) 3560

by devdevil85 In reply to I cannot ping GW of last ...

Just so you know CG....only 1 3560 we are using....

Collapse -

yeah so VTP really isn't an issue

by CG IT In reply to Yeah I only have (1) 3560

because you don't need to populate other switches with the VLAN.

Collapse -

we have a L2 Adtran swtich here that we might add

by devdevil85 In reply to yeah so VTP really isn't ...

later so VTP will become a concern then, but for now it's all going to be internal to the 3560.

Collapse -

more guess-itude?

by robo_dev In reply to Where do I point devices ...

Show vlan brief
Show interfaces switchport
Show ip interface brief
Show int trunk

does the port status show fully active (administratively up and line protocol up)?

Collapse -

What I found out

by devdevil85 In reply to more guess-itude?

This is what I got:


User Access Verification

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/23, Fa0/24, Gi0/1
Gi0/2
10 VLAN0010 active Fa0/22
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
Cisco_POE#show inter
Cisco_POE#show interfaces switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false

Cisco_POE#show interfaces f0/22 switchport
Name: Fa0/22
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: Off
Access Mode VLAN: 10 (VLAN0010)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Cisco_POE#show ip interface brief
Interface IP-Address OK? Method Status Prot
ocol
Vlan1 192.168.1.7 YES NVRAM up up

Vlan10 192.168.10.1 YES manual up down

FastEthernet0/1 unassigned YES unset down down

FastEthernet0/2 unassigned YES unset up up

FastEthernet0/3 unassigned YES unset up up

FastEthernet0/4 unassigned YES unset up up

FastEthernet0/5 unassigned YES unset up up

FastEthernet0/6 unassigned YES unset up up

FastEthernet0/7 unassigned YES unset up up

FastEthernet0/8 unassigned YES unset up up

FastEthernet0/9 unassigned YES unset up up

FastEthernet0/10 unassigned YES unset up up

FastEthernet0/11 unassigned YES unset up up

FastEthernet0/12 unassigned YES unset up up

FastEthernet0/13 unassigned YES unset up up

FastEthernet0/14 unassigned YES unset up up

FastEthernet0/15 unassigned YES unset up up

FastEthernet0/16 unassigned YES unset up up

FastEthernet0/17 unassigned YES unset up up

FastEthernet0/18 unassigned YES unset up up

FastEthernet0/19 unassigned YES unset up up

FastEthernet0/20 unassigned YES unset up up

FastEthernet0/21 unassigned YES unset up up

FastEthernet0/22 unassigned YES unset down down

FastEthernet0/23 unassigned YES unset up up

FastEthernet0/24 unassigned YES unset up up

GigabitEthernet0/1 unassigned YES unset down down

GigabitEthernet0/2 unassigned YES unset down down

Cisco_POE#show int trunk

Cisco_POE#

Collapse -

From the cisco site:

by robo_dev In reply to What I found out

your port 22 is down/down:

From Cisco:

If the interface status is down/down, verify the VTP configuration and that the VLANs have been added to the VLAN database. Check to see if a port is assigned to the VLAN and whether it is in the Spanning Tree forwarding state.

http://www.cisco.com/warp/public/473/howto_L3_intervlanrouting.html

Collapse -

VTP?

by devdevil85 In reply to From the cisco site:

Was I supposed to setup VTP? I thought it was optional. I figured since I'm trying to just use the switch for L2 & L3 I wouldn't need to implement that. Is that a wrong assumption?

Collapse -

well you don't have to run VTP

by CG IT In reply to VTP?

but it does make things easier.

Back to Networks Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums