Question

Why can my network adapter send packets but not receive them?

By bboy_nico ·
Hi. I am new to this forum, so I hope I am posting this question in the right place.

With all this COVID-19 situation, I am trying to help my niece achieve a laptop so she can take classes with the teacher online.

I had an old Acer Aspire One ZG5 (AOA 150 - Bw) that I am trying to prepare for her. However I am struggling with network problems for a couple of days now...

So, before formatting I was not able to find WIFI networks. After re-installing the WIFI driver, I was able to connect it to my home local network, I did some downloads, accessed pages, etc. As I had other problems (cam drivers problems, performance issues), I have decided to format the notebook with Windows XP Professional x32 (previously it had the Windows XP Home Edition x32). I have installed the official Acer tool that had all the original and right drivers (after a couple of formats eheh).

What happens is I can't access the network, even if I get the good quality signal. I have noticed that some packets are sent but no packets received. The only ones I was able to receive, I think it was the DHCP ones from the router because I can get the new IP from the router. However it is strange that I receive the same IP before formatting and I removed it from the router myself (using the admin page).

I can't ping the router (dns/dhcp - 192.168.1.1), I can't ping other devices connected to the same router. It gives me the timeout issue with 0 packets received (= 4 packets lost). I've tried many things. I am able to ping device to device (all the other ones I have connected to the same network and that are 100% functional), other device to router, etc. With the LAN cable I can ping from the notebook to the router and/or other connected devices, that also can ping this notebook. However, I can't login on the router's page (I can connect to it only, other pages won't work). I also can't ping www.google.com or 8.8.8.8, but I can ping locally 127.0.0.1.

I found this really really odd and it is giving me headaches. The only problems that are occurring to me are right now are:
- wrong/problematic WIFI drivers;
- messed up WIFI board.

Nevertheless, I think the notebook would not be able to connect to the router DHCP in order to get a new IP address If one of the above problems were happenin...I have already tried with manual and with automatic IP and the problem mantains. The renew and release IP don't solve, I have flushed the DNS...nothing.

Can someone help me out with some tips/hints, please?
Thread display: Collapse - | Expand +

All Answers

Collapse -

I'm using the same netbook right now!

by wizard57m-cnet Moderator In reply to Why can my network adapte ...

Couple things I suggest. First is update to WinXP SP3, if you can find it on Microsoft website. This will at least get you the most up to date security for WinXP, and while at it try to apply the security updates if still available. Then, you'll need a bit more up to date web browser...forget Firefox, Chrome...they just don't support XP anylonger. I suggest a Palemoon community developer release named New Moon by Roytam. Using it now, has been rock solid.
Now, here's the most likely cause of your network problems...the driver! The base driver included in the re-install image from Acer is an older one and does not support the more recent WiFi protocols! What to do, what to do?? Several years ago I stumbled across the last known update for the Atheros wifi adapter on this Acer Aspire One AO150...Wireless LAN_Atheros_7.7.0.456_XPx86_A.zip, can't remember where at the moment. This newer driver lets my wifi access new hotspots and wifi devices.
So, that's my advice...search using duckduckgo, Bing, google or whatever you prefer and see if you can find these. If you can't, send me a PM, I'll see what I can do.
Wiz

Collapse -

I'll try this new drivers

by bboy_nico In reply to I'm using the same netboo ...

Hi wizard57m-cnet.

The Windows XP already came with the SP3. I would search for more updates if I was able to access the Internet

The base driver version is the same as the one I have installed before the first time I have formatted:
- https://www.notebook-driver.com/acer-aspire-one-aoa150-windows-xp-drivers/:
- https://www.acer.com/ac/en/ID/content/support-product/61;-;

I have noticed that the ones you pointed out are more updated. I found them and I will try it in a couple of minutes and see if it works out :)

I'll post some feedback as soon as I am able to do it.

Collapse -

Solved!

by bboy_nico In reply to I'm using the same netboo ...

I found and installed those drivers and now it is solved!!!! I can ping everything (local devices, router - dns/dhcp, internet, etc). I am now running automatic windows updates to update everything and continue with the working.

Thank you very much wizard57m-cnet| You saved my day! :)

Collapse -

Glad to be of help!

by wizard57m-cnet Moderator In reply to Solved!

I've used this little Acer for years, lol! I kept WinXP SP3 Home Edition on mine, and I also multi-boot with a few versions of Slackware based Puppy Linux distributions. I'm partial to one called ScPup 32 bit (the CPUs on these old Acer AO150s only support 32 bit OSes, Intel Atom N270). I use Palemoon browser with my puppies, lol! Palemoon, and New Moon, are based on the older Gecko versions from Mozilla, but with UA telling sites it's "Firefox" I don't have any problems accessing sites I frequent!
Good luck, and hope your niece gets as much use from your Acer as I do mine!
Wiz

Collapse -

:)

by bboy_nico In reply to Glad to be of help!

Didn't know those browsers, I ill check them.

The notebook is almost prepared. Still need to figure a network/certificate issue out. Some websites, I am assuming those with SSL certificates, are not loaded. In every site it keeps displaying the not secure website (even on youtube, etc). I have tried many things:
- Installing the website certificates;
- Turn off firewall;
- Added exceptions on firewall;
- Messed with some IE configurations;
- Changed date/time.

But nothing seems to work. I have noticed some due certificates but it seems they are not validated anymore. For example: on youtube, even after installing the certificate, the message keeps displaying and not all content is loaded. But I am still trying to figure this one last thing out :)

Related Discussions

Related Forums