General discussion

Locked

Why can't I FTP?

By paul.eggers ·
I have WinXP Pro at home on a Dell 8400, with 512 MB RAM. I used to be able to access FTP sites, but not anymore. I'm using IE6, but I've tried Firefox also. When I try to access an FTP site, my browser just hangs. I have virus protection, and run Spybot regularly.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by robo_dev In reply to Why can't I FTP?

Windows Firewall blocking FTP?

Try using FTP from the cmd prompt and see if it works that way: e.g. ftp www.microsoft.com

Collapse -

by paul.eggers In reply to Why can't I FTP?

Have turned off Windows Firewall... have not tried the DOS prompt method. Will get back to you on that one.

Collapse -

by zlitocook In reply to Why can't I FTP?

Have you checked with your ISP? They could have turned something off or upgraded and not be aware that there is a problem. Or is it just one site you FTP to, mabie they are having a problem.

Collapse -

by paul.eggers In reply to Why can't I FTP?

It's more than 1 FTP site that I can't get to.
I never thought to ask my ISP... will give that a shot.

Collapse -

by Dumphrey In reply to Why can't I FTP?

Couldnt hurt to download a nd try an ftp client like cuteftp or such..may help sort between an OS problem and a network problem.

Collapse -

A fix that worked for me

by Toolsmythe In reply to

I have a nightly job that runs an FTP script to get the latest virus protections from my virus protection vendor. The script runs on each of my machines in my network and has been working fine for over two years. Until three days ago when it stolled woring on my XP Pro (SP2) workstation.

I tried re-booting, I applied all the latest upgrades, no joy. Anything to do with FTP: the native client, a third-part client, even a C# app I wrote that uses the .NET framework's FTP code all failed. I could attach to a server but I could not read from, write to or even get a directory listing.

If I disabled the Windows firewall, everything worked OK.

It took a bit of searching, but I found something on technet that mentioned the Application Layer Gateway Service. While it did not specifically recommend stoping and restarting this service, I did ..... and it worked!

Give that a try.

JP

Collapse -

restarting Application Layer Gateway Service worked

by angelo In reply to A fix that worked for me

i encountered the same issue. FTP was working then suddenly couldnt connect. only if windows firewall turned off i could get a connection.

restarting the ALGS worked for me too.

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums