Why can't my Vista machine see my XP shares?

By BryanMohr ·
I've read so many posts about this and tried so many different things but none has solved my issue. I have 7 computers all networked together. My "Main" computer is named "C210" and is running Windows XP. Four others are also running XP, 1 running Ubuntu, and then the last one is running Vista 64. They all have shared folders. C210 has the largest share and all of the printers attached. All computers can read/write files with each other and all can access the C210 printers without a problem ... except when it comes to the Vista machine. Vista can read and write to all of the other machines except for C210. It can see C210 on the network but trying to view it's shares always asks for a login. None of the other computers ask for a login, only C210. And of course, the login is never correct. The same usernames and passwords exist, simple file sharing enabled or disabled doesn't make difference, guest account enabled/disabled makes no difference, it is the same workgroup name across all computers. I've uninstalled Norton on C210 to see if that was the problem, no difference. I can ping C210 from Vista with no problem so it is being seen. Trying to do "net view \\C210" returns "System error 5 has occured. Access is denied." but trying a different machine name works just fine and shows all of the shares on that machine.

What is stopping only the Vista machine from accessing only the C210 XP computer? After I removed and subsequently reinstalled Norton, I made sure to give "Full Trust" to all of the computers again, including Vista.

Please help!

This conversation is currently closed to new comments.

67 total posts (Page 1 of 7)   01 | 02 | 03 | 04 | 05   Next
Thread display: Collapse - | Expand +

All Answers

Collapse -

If you put in the usernames and passwords..

Too often it times out, meaning you will have to wait a minute. The best way is to reboot your Vista machine and see if you can input your Username and password again.
Make sure ALL of your computers are up todate and try again.
Make sure your XP machines have "LLTD" on them,
LLTD here:

More information that might help you here:

Collapse -

Reponse To Answer

by BryanMohr In reply to If you put in the usernam ...

It does not time out. It immediately returns with the invalid login popup. //i have tried rebooting, many many times now.

All computers are completely up to date. None of the XP machines have LLTD on them because they all have SP3 installed which does not allow LLTD to be installed. But again, only C210 (1 of 5 of the XP machines) is having this problem. So I do not believe that it's a problem with SP3, or the absence of the separate LLTD installation.

Collapse -

Link Layer Topology Discovery (KB922120) not included in SP3 no problem..

More info here for you to install LLTD to your machines so that they can be seen with Vista:
Enjoy. :)

Collapse -

Reponse To Answer

by BryanMohr In reply to Link Layer Topology Disco ...

Nope. That's not it. I went through the instructions and everything went just like you said it would, even after installing the responder. But the same thing still happens on the Vista machine. It is STILL asking for a username and password.

Collapse -

seems to be a security settings issue

by Sandy@ In reply to Why can't my Vista machin ...

You will need to downgrade security settings of your vista machine to NTLM v1 or upgrade other systems to use NTLM v2. The solution is to force Windows Vista to use the older encryption methods. To do that, follow these steps:

Users of Windows Vista Home Basic and Home Premium

Click start
Type: regedit
Press enter
In the left, expand these folders: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
In the left, click on the folder named: Lsa
In the right, double-click "LmCompatibilityLevel"
Type the number 1 and press enter
Restart your computer

Users of Windows Vista Business, Enterprise, and Ultimate

Click Start
Click Control Panel
Click System and Maintenance
Click Administrative Tools
Double-Click Local Security Policy
In the left pane, click the triangle next to Local Policy
In the left pane, click Security Options
In the right pane near the bottom, double-click "Network security: LAN manager authentication level"
Click the drop-down box, and click "Send LM & NTLM - use NTLMv2 session security if negotiated"
Click OK

Collapse -

Reponse To Answer

by BryanMohr In reply to seems to be a security se ...

Still not the problem. This was done long ago but I thought I'd check it again just to make sure. It is still set at 1. Besides that ... it's not the Vista machine that really has the problem since it can access the other XP SP3 machines just fine.

Collapse -

Username and password?...

So, if you know about the XP machines Username and Password, why not put it in?
You might need to check to see that you are inputting the correct username and password. Try and change the Username and password on your XP machine and go from there. Make sure ALL machines are on the same WORKGROUP.

Collapse -

Reponse To Answer

by BryanMohr In reply to Username and password?...

I do enter the username and password but it always returns "Logon Unsuccessful". All machines are using the same username and password (I'm not worried about security since I am the only one with physical access to the computers). And yes, they are all on the same workgroup except for the Ubuntu machine, but that's not an issue anyway. I tried changing the username and password temporarily on the XP machine but still got invalid login, so I just changed it back so I wouldn't introduce new problems to all the other computers.

Collapse -

another thought..

by Sandy@ In reply to Why can't my Vista machin ...

what i have seen with systems in workgroup, sometimes we need to explicitly pass user name and password to access them. I used to map a drive using a batch file with net command:

You may want to try this if you have not tried it already.

PS: i tried to put full command line here but that was not displayed correctly. use "net use /?" to get help and try mapping a drive of target system share.

Collapse -

Reponse To Answer

by BryanMohr In reply to another thought..

C:\Users\Bryan>net use \\C210\Documents
System error 53 has occurred.

The network path was not found.

Yes, Documents is the share name on C210. All other computers can read and write to it just fine. No login necessary even.

Back to Malware Forum
67 total posts (Page 1 of 7)   01 | 02 | 03 | 04 | 05   Next

Related Discussions

Related Forums