Question

Locked

Why would single port forwarding suddenly stop working?

By Nukolas ·
I recently created 5 port forwards for 5 individual users to remotely connect to their machines in the office from home. I designated the port numbers in the router (Linksys WRT300N) and pointed them to their static IP addresses. I also changed their default port number in their Windows registry on their machines. All steps were covered and I was able to successfully connect to their machines from outside of the domain.

Essentially, it works like this. From my PC I use remote desktop and connect to their domains public IP address and tack on their port number at the end.

66.16.XX.XX:3394

All was working great but now, nothing. Also, if I attempt to remote desktop to their machines within the domain (say from the DC) I get that annoying error stating; "the client could not connect to the remote computer." I CAN ping their IPs.

It's all very confusing and for the life of me I can't wrap my head around it. Any help would be greatly appreciated!

Please let me know if any other details are required.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

go back to the default configuration

by CG IT In reply to Why would single port for ...

try that, if that works without problems, you've isolated the problem.

Note: even though you've made registry setting changes, it's possible those changes aren't taking effect. That's where going back to the default configuration will help with fault isolation.

Collapse -

I did try that

by Nukolas In reply to go back to the default co ...

Forgot to mention, that was actually one of the first things I tried when it stopped working.

Collapse -

did you revert the workstations back to previous settings?

by CG IT In reply to I did try that

I tend to think it's your registry edit and is causing the problems and not the router.

If you have firmware for the router, you can reload that and see if that fixes the problem, but again, I think its the registry edit you did on workstations to change the default listening port.

Collapse -

Some things to try

by Choppit In reply to Why would single port for ...

Try using nmap against the public IP to determine if the port is forwarded and listening

nmap -sT -p3394 <public ip>

Also try netstat on the target host to determine if it's listening on the expected port.

netstat -a

If the nmap scan shows the correct port as open and it's still not working then I'd suggest bouncing the RDP service.

Collapse -

I'll give that a shot

by Nukolas In reply to Some things to try

I'll give that a shot. And if that doesn't work, I guess I'll just have to bounce the service like you suggested.

Thanks!

Collapse -

Resolved!

by Nukolas In reply to Some things to try

Really strange. It dawned on me to remove and re add the machines in question to the domain so that the GPO would refresh. I did that and we're back up.

Thanks for all of the help!

Back to Software Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums