Will HP Pavillion dv6119US Support an AMD Turion 64 X2 Mobile TL64?

By garyadler21 ·
Does anyone happen to know if an AMD Turion 64 X2 Mobile TL64 2.2GHz CPU would be supported by an HP Pavillion dv6119US? It came with a TL50. I have updated to the latest BIOS version F.42, released on 2009-03-25. If the BIOS does not support the TL-64, what would be the fastest processor it does support?

TIA for the input.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Well there are several things that you need to check first here

by OH Smeg In reply to Will HP Pavillion dv6119U ...

The main one is that you actually have a changeable CPU in this unit. Many NB CPU's come soldered to the M'Board and are not changeable.

Here is the Specifications for this NB according to HP at lease.

Owing tot he fact that this unit has such low Specifications like only a max of 2 GIG of RAM and so on I would hazard a guess that no you can not change the CPU here.


Collapse -

Thanks for the reply! - CPU is changeable

by garyadler21 In reply to Well there are several th ...

I have installed the AMD Turion 64 X2 TL64 but depending on the RAM I throw at it, it either will not start or freezes up once it does. I was guessing that perhaps the (updated) BIOS does not like the CPU but I am only guessing. I ran Prime 95 without errors for 17 hours with the stock TL50. I even replaced the 2 x 512MB DDR2 with 2 x 2048MB PC2-8500 DDR2 I had just to see if I would get away with it and ran Memtest without errors overnight. These successes encouraged me to try the faster CPU. Thanks again for the help.

Collapse -

SOLVED! Thanks for the help.

by garyadler21 In reply to Thanks for the reply! - C ...

I have discovered that the TL64 does, indeed, work with the HP Pavillion dv6119US.

Collapse -

any advice?

by Mash13 In reply to SOLVED! Thanks for the he ...

I'm tryingto do the same upgrade. Can you share any advice? BIOS used, Ram used, anything else that you did that made it work finally. Thanks.

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums