General discussion

Locked

win 2000 dns

By jim.anderson@accesspoint ·
I just set up a win 2000 server ( domain controller) and 15 win 2000 workstations.I have pointed all workstation to the DC as thier DNS server and set the server to forward to my ISP( have also check the box do not do recurvsive)after doing this, all the workstation are very slow to access the internet, also the server is slow to access the internet, if i add my ISP's dns servers to all workstations and the DC as additional dns I can then access the internet fast. Is this setup ok, what my I bedoing wrong
The server is not the root server and I have not deleted the root hint file. I have a dsl connection with a linksys router, the router is the default gateway.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Yes

by james.wilson In reply to win 2000 dns

This should be fine. Use the DC as the primary and set your secondaries to your ISP's DNS. This way your workstations wont't have to wait for your server to forward. That being said...the time lapse between the 2 setups should be nominal.

Collapse -

what about the dc

by jim.anderson@accesspoint In reply to Yes

should i set the isp's dns as additional dns on the server tcp/ip properties or just setup forward

Collapse -

Forwarding should be sufficiant

by james.wilson In reply to what about the dc

Forwarding should be sufficiant

Collapse -

by colin In reply to win 2000 dns

Is the server also pointed to use itself for DNS?

Collapse -

server is pointed to its self

by jim.anderson@accesspoint In reply to

the server is pointed to its self as its dns.
I also have my isp's dns server as additional dns server and have forwarded Enabled

Collapse -

let me clarify

by omie In reply to win 2000 dns

Is there a reason why you configured the server as DNS ? I only enable the server to use the as a DNS server if I am using some application in a intranet setting. If you don't feel the need of intranet let the linksys router do the DNS resolution. In the server configuration add the DNS entry provided by your ISP, so that you could connect to the internet. What I suspect is that you are having a loop because of having two DNS server .The router as a gateway has its own DNS entry and the serverdoes it own thing and that may be reason why you have slow internet. Try to disable the the server DNS services and let the router do the forwarding of DNS query connection.

With the IP forwarding ... that is a critical move. You are opening your system to the outside world.

Back to IT Employment Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums