General discussion

Locked

WIN-NT 'at' command

By jsecking ·
I'm tring to use the 'at' command to schedule an automatic backup process.
After the process, displayed in the STATUS is 'error'. I can not find documentation to help find what my 'error' is. The HELP message only shows how to build the 'at' command and does not indicate how to view the results.

thanks.......JOHN

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Post It

by SyscoKid In reply to WIN-NT 'at' command

Post your AT command so we can see it. Also, you have the Scheduler service running, right?

Collapse -

screen shot of command

by jsecking In reply to Post It

c:>at 17:11 ftpcopy.cmd
Added a new job with job ID = 1

c:>at
Status ID Day
---------------------------
1 Today

c:>at
Status ID Day
---------------------------
Error 1 Tomorrow

***************************
Here is acopy of command that is to execute.
***************************
c:>type ftpcopy.cmd
ftp -i -n -v -s:ftpscript.txt

..........JOHN

Collapse -

Does it run on

by jgee22 In reply to screen shot of command

Does it run locally or network? If you run it on the network, you may have to supply an userid and password that has permission to run services on the network.

Collapse -

more info

by me01 In reply to screen shot of command

need condence of ftpscript.txt you can change the info with xxxxxx for security if needed. does the ftpcopy.cmd run without the at?

Collapse -

command OK by itself

by jsecking In reply to more info

The ftpscript command run OK by itself.
I am trying to setup an automated/unattended execution for this script using the 'at' command. The 'at' command will let me schedule as a job but shows 'status = error' at complation with no explanation for the error.

Collapse -

error

by me01 In reply to command OK by itself

i have set alot of these up and the only time i get erors is when nothing happends. you are saying the the ftp happeneds but you get the error anyway? are you useing the short dir and file names?
example:c:\program files\direct\file.cmd c:\progra~1\direct\files.cmd
what was typed for at

at 12:00 /every:monday,thursday "c:\progra~1\direct\files.cmd"

_______________

have you tried winat of the resource kit it will give you a gui for the at command it is easier sometimes.
me01

Collapse -

response

by jsecking In reply to error

No, I saying that I can run the ftp as a batch job and I get the desired resvlts. Running with the 'at' command no results on the ftp file and an error on the status line of 'at'.
SEE early relply for screen copy of command entered.
------------------
I tried the WINAT and I do not get results and no error is displayed. The scheduled job just goes away.......

Collapse -

sorry but check it out

by me01 In reply to response

the server is running this local he being the server needs a full path to the command sometime. so it disappeared when you did it through winat. the winat will not let you do once for the same day as you are doing it so i have found at clich in that part of the gui. i know you have the file in a place that is in the path but just hummor me please.

Collapse -

some things to try

by cbonnet In reply to command OK by itself

I had to mess with AT once, and through trial and error got it working. I don't remember all of the details exactly, but I do still have the command I used to get it to work. I had a lot of trouble getting a simple net time synchronization to work...eventually this is what performed for me.

\\oemfsky is the local machine that I was trying to get the time set on, \\hoemxin was the machine we had connected to a master time clock (through the serial port). Good luck,

at \\oemfsky 5:10 /interactive /every:m,t,w,th,f,s,su "c:\xintime.bat"

c:\xintime.bat=
net time \\hoemxin /set /yes

Back to IT Employment Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums