General discussion

Locked

Win Server 2K3 (Standard) & OfficE 2K

By Ozzie21 ·
I am havning problems saving files to a Shared Folder. When I set the SECURITY permissions to DENY the DELETE and DELETE SUBFOLDERS AND FILES.

OS=WinXPPro & Office2K. When I attempt to save to Shared Folder I get a message "the folder is READ ONLY" I have UNCHECKED READ ONLY on the Shared Folder (Hopeing that it will remove the READ ONLY). When I check the propeties a second time READ ONLY with a Grey Check Mark is back. If I remove the DENY DELETE and DELETE SUBFOLDER AND FILES from the SECURITY tab I am able to save to the shared folder. Has anyone else experienced this & is there a soloution any help is appreciated

I do not want to allow any user, but Admins, to delete folders or files within the Shared Folder. I have tried using DENY DELETE & DENY DELETE SUBFOLDERS AND FILES each of them separate. I have also tried unchecking the ALLOW DELETE & DELETE SUBFOLDERS AND FILES & users are able to delete files & folders. For some reason both DELETE & DELETE SUBFOLDERS AND FILES need to be DENY in order to prevent users from deleting files/folders in the shared folder. But when both are checked I get the Folder is READ ONLY Message and doesn't allow me to save to the Shared Folder.

This is what I've done:
ADDED A SHARED FOLDER called Shared Folder in the E (E:\SHARED FOLDER). I Added EVERYONE, ADMINISTRATOR, & USER285 & given FULL CONTROL in the SHARED PERMISSIONS tab. In the SECURITY tab I have given ADMINISTRATOR FULL CONTROL and EVERYONE & USER285 READ & EXECUTE, LIST FOLDER CONTENTS, READ, WRITE, & SPECIAL is grey with grey check in ALLOW & DENY. The ADVANCE shows that EVERYONE & USEER285 have DENY SPECIAL (With Check marks in DENY on DELETE and DELETE SUBFOLDERS AND FILES) and they also have ALLOW everyting checked except FULL CONTROL & DELETE & DELETE SUBFOLDERS AND FILES. These setting do not allow any user to DELETE any files/folder(Except for Administrators) but these setting also prevent me from saving a doc because I get the Folder is READ ONLY

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to Win Server 2K3 (Standard) ...

Ozzie what group policies do you have in place? If any? [you did say this is Windows 2003 Server & Office 2000. It is quite possible that group policy in effect for the group those users belong to are overriding your specific folder permissions e.g. group policy for the everyone group or domain users group.

Collapse -

by ariston In reply to Win Server 2K3 (Standard) ...

Typically if a check box is grayed out with a check mark it is most likely inheriting permission from the parent folder. Go to the Security tab of the shared folder and try removing everything from the permission list. You may receive a dialog box stating that certain permission are being inherited from a parent and asks if you want to copy or remove the permission. Select Remove, and then manually add the users you want to have access, and then specify the permissions they need to have.

Hope that helps!

Ariston Collander
ariston@coxcomputer.com

Back to Windows Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums