General discussion

Locked

Win XP disk boot failure

By shpl ·
I have a system on which there is only one HDD with XP loaded but the system is refusing to boot without the XP installation CD in the CD-ROM drive. This is a new system that was under construction and the only time XP was booted was with the installation done by the CD in the CD Drive. After we power on and we get the error message "DISK BOOT FAILURE - INSERT SYSTEM DISK AND PRESS ENTER" and we put the CD in and press enter - sooner or later the system is running on the XP loaded on the hard disk and we can take out the installation CD to no interruption on the XP functioning itself. How do I get rid of the need to have the installation CD in the ATPI CD ROM drive. I have even tried uninstalling and taking out the CD drive but then the system just doesnt load any XP till the CD is put right back in place. I have tried doing bootconfig application but it is not working. How can I remedy the disk boot failure and get going with what I have got on the HDD or a fresh install and not have to depend on the installation CD for every boot.

This conversation is currently closed to new comments.

21 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by mjd420nova In reply to Win XP disk boot failure

Check the boot sequence in the BIOS, reset to look for the hard drive first, then any other next or some will allow boot from HD only.

Collapse -

by zlitocook In reply to Win XP disk boot failure

Try doing an in place repair, boot to the CD the choose repair. It could be that the boot sector is damaged, boot to the CD, repair and do a format /mbr and reboot with out the CD.

Collapse -

by secor941 In reply to

format /mbr is not a valid command

Collapse -

by shpl In reply to Win XP disk boot failure

I have done a FDSIK/MBR again and again and even loaded Windows 98 on top of Windows XP to delete that install and so wrote on the MBR (master boot records) many times. But the problem refuses to go away. Also in my BIOS if I remove the install CD(whether 98 or XP) as an option for boot up the system doesnt load at all. How do I change or reset o rewrite the BIOS software because I am also getting a FLASH BIOS UNKNOWN message at the POST message stage on powering on. But the BIOS version is shown from Award Software for 810ET.

Collapse -

Try this

by IC-IT In reply to

Replace your motherboard battery, reboot to BIOS and reset to defaults.
Check your settings (in BIOS) insure any BIOS virus protection is turned of and that PNP OS = No.
Reinstall XP. Do not use the fdisk /mbr option on an XP installation. If needed use the Recovery Console Fixmbr command. You may also need to run fixboot and bootcfg /rebuild.
edited to add: should you still feel a need to upgrade (flash) the BIOS; identify the motherboard/manufacturer and go to their site for the file and instructions.

Collapse -

Weak HD Motor

by jnc01 In reply to Win XP disk boot failure

I have the same problem. This is just my theory, but I'm thinking the HD isn't spinning up properly. By making the system check the CD Rom before going to the HD, its giving the HD time to stablize.

I've replace my power supply with a better one, and still have the problem. I've even put the HD on its own power rail, but it is still buggy.

I'm guessing impending failure.

That's what I get for buying recertified drives.

Collapse -

How old is the HDD?

by MyLittleMansAnIdiot In reply to Win XP disk boot failure

If it's an old drive, it may just be that the MBR sector is corrupted or physically damaged.

Try running the recovery console from the Windows CD and using FIXBOOT command to attempt to rewrite the MBR. If this doesn't work, I'm guessing what I said above is true.

Collapse -

RE: How old is the HDD?

by jnc01 In reply to How old is the HDD?

If it was un-recoverable, I'd agree. But the fact that it boots fine after the delay makes me think its something other than bad MBR.

Collapse -

How I solved this problem

by tkman28 In reply to Win XP disk boot failure

I had this exact problem.
I surfed the web and tried all kinds of things.
I tried new cables, the hard drive in a different machine as a slave, I ran disk tests, I reinstalled twice, I checked for viruses, tested the power supply,...etc.
I submitted a question to the Western Digital folks to see if they had an answer. Nothing.
I was about to buy a new hard drive but decided to talk to the tech guy first.

Thanks to my local PC store tech guy he suggested I check the jumpers on the drive.

I have always set the Jumpers to Master when there is only one drive in the system.

With Western Digital this causes weird failure.
I totally removed the jumper and the system started beautifully. I then set the jumper to cable select and had the drive attached to the last connector and this worked beautifully as well.

Thus before trying all the other stuff look at the hard drive and the pins beside the data cable. There should be some indication as to what pins are for Master, slave, and cable select. Either remove all jumpers or go with cable select.

Hope this works for you.

Collapse -

Of course, I have the problem and its SATA, so...

by jnc01 In reply to How I solved this problem

Of course, I have the problem and its SATA, so...

Back to Windows Forum
21 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums