win XP internet connection sharing

By alexdevaraj ·
Hello All,

I dont have much experience in networking hope some one can help me with this.

I am in a school network with ip address 166.X.X.X. My XP PC is connected to the network i have an ip of 166.X.X.X. ( i will name my PC as 'PC A'). For a specific project we purchased a win NT 4.0 workstation PC ( i will call this PC 'PC B') and wanted to connect to our network 166.X.X.X so we decided to do a ICS ( internet connection sharing) with my PC A which is in XP everything went well and the PC B was assigned a ip of 192.168.X.X we are able to surf network with both PC A & PC B . but when we want to share files to PC B from my friends PC whos is in the network with ip 166.X.X.X the PC B does not shows! also when we ping the ip of PC B '192.X.X.X' from our ip 166.X.X.X there is no responce but i am able to share files from PC A and also able to ping from PC A.

Is this a limitation in ICS that the client PC will not be shown outside the internal network? any solution to solve this is much appreciated I was suggested that i need to use a dual LAN server if i need to see the clients outside the internal networks...

The reason for me to ping is i need to send some packets to this PC B and wants its response to this.

Thanks, sorry for long description!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Not sure how you have it working but.

by 1bn0 In reply to win XP internet connectio ...

Change the second machines workgroup name to match the workgroup/domain name of the first pc.

XP machines will ignoire each other if they are not in the same workgroup.

Also check to see if you have the firewall enabled on the second p.c. if the different IP addressing schemme is working, the computers will see each other as being on different networks and firewall each other. IFthey are on the same network (ip/netmask range) they should allow sharing between them. Other wise you will need to re-configure or diable the firewall. Might not be recommended though.

Collapse -

Also, to add, If and when you make changes, make sure you re-boot...

by Peconet Tietokoneet In reply to Not sure how you have it ...

Both computers for the connections to work.

1). make sure all computers are in/on/with the same network domain, I:E, WORGROUP.

2). If and when you do this, the computers will ask if you would like to save the settings on a device, I:E, flash drive, floppy, etc. Make sure you save the settings on one of these from one computer and then go to the other computer and copy over the settings from the disk or flash drive.

3). When all is done, please re-boot BOTH computers so that the settings take affect.

Related Discussions

Related Forums