Win16 cannot enter protected mode

By afu ·
I am trying to load a program onto my computer (a program with multiple updates that won't load unless it sees the original program on the drive). I get an error message: "The Win16 subsystem was unable to enter protected mode. DOSX.EXE must be in your AUTOEXEC.NT and present in your PATH". How do I fix it, and how do I edit/create new any files that are needed? I'm using Windows 2000 Professional

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Must be an OLD proggy ...

by OldER Mycroft In reply to Win16 cannot enter protec ...

What is it ?

There might be an easier way.

Collapse -

Is 13 too old?

by afu In reply to Must be an OLD proggy ...

It is AutoCAD LT 2000, but it was an upgrade of AutoCAD LT 95. So I can't even load 2000 upgrade unless it sees the full 95 program first. I'm doing some design from home and it is not cost effective to go to a newer version. I successfully loaded it on a WIN2000 laptop, but now want to put it on a desktop.

Collapse -

You gotta love DOS

by bart777 In reply to Is 13 too old?

You need to do exactly what it's asking. Since Windows 95 rode on top of DOS is works differently than Win2K. When a virtual ODS machine is called it looks in the autoexec.nt file for it's settings.

Simply add the information it's requesting to the file or edit the line that has the mapping so that the program will find the correct version of DOS that it's looking for.

You may need to find your 95 disks to get the correct DOS file.

Let us know if you have any issues.

Best of luck.

Collapse -

Therein lies the problem . .

by afu In reply to You gotta love DOS

What lines do I add to what files, and how? Web searches say to add certain lines to autoexec.nt using notepad, but when I go to save it, it saves as a text file. That doesn't sound right.

I guess what I'm asking is, step by step, what do I do. As I said, I loaded it on a laptop with no problem. Do I copy the autoexec.nt, dosx.exe, etc files from the laptop into the same directories on the desktop?

Collapse -

Not a problem

by bart777 In reply to Therein lies the problem ...

If the file name changes when you edit it just rename the file when you are done.

And you should already have the autoexec.nt file on your desktop. It may be hidden.

Collapse -

Still not clear

by afu In reply to Not a problem

My question is, what do I change in those files, which files, and where do I put them once I've changed them? Notepad saves it as a text file, but gives me a choice between ANSI, Unicode, Unicode big endian and UTF-8 type codings? Config.nt in the WINNT\system32 directory says it is an "NT" file, not a .TXT file.

I'm computer savvy, but not that computer savvy.

Collapse -

Just rename the saved file ...

by OldER Mycroft In reply to Still not clear

If Notepad insists on saving a file as 'Autoexec.txt' then navigate to where it is, right click on it, then RENAME it by changing the extension so that it is end up as 'Autoexec.nt'.

It really is that simple. :)

Related Discussions

Related Forums