Question

Locked

Windows 2000 not reading NTFS drive

By NickStudent ·
I have an IDE drive with a lot of important data, all on one NTFS partition. It was hooked up to a XP machine, and worked great. My XP machine went down, and I am not in the position to buy another machine right now. I had an old machine lying around that had windows 98 on it. I installed Windows 2000, which still won't read my drive. The BIOS sees it correctly, and my roommate's XP machine reads it fine, so I know it is not dead. I see it in Windows Explorer, but the volume name is gone (It is just called Local Disk). If I try to access it, it says that it is not formatted. any ideas of what I am doing wrong? Is it related to the machine being built for Windows 98, which didn't support NTFS?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

NTFS 4.0 vs NTFS 5.0

by sweaver72023 In reply to Windows 2000 not reading ...

Nick
I hate to be the barer of bad news but this is a Microsoft enhancement. The NTFS used in Windows XP and Windows 2003 is actually NTFS 5.0 and it is formatted a little differently that the NTFS 4.0 found in Windows 2000. Another problem that adds to this is the use of dynamic vs basic drives. If the drive is dynamic and formatted with Windows XP NTFS, Windows 2000 will never see it.

Collapse -

EnableBigLba Registry Setting in Windows 2000

by jmh.smits In reply to Windows 2000 not reading ...

Probably your hard disk exceeds 128 GB/137GB
Windows 2000 SP3 add support for 48-bit Logical Block Addressing (LBA), which lets you access hard disks larger than 137GB. To enable 48-bit LBA with Windows 2000 SP3, you must also make sure the EnableBigLba value is defined and set properly in the Windows registry.
To enable EnableBigLba in the Windows 2000 registry, perform the following steps:
1. Start a registry editor (e.g., regedit.exe).
2. Navigate to HKLM\SYSTEM\CurrentControlSet\Services\atapi\Parameters.
3. From the Edit menu, select New, DWORD Value.
4. Enter the name EnableBigLba, then press Enter.
5. Double-click the new value, set it to 1, then click OK.
6. Close the registry editor.
7. Restart the machine for the change to take effect.

Or download this tool to fix the registry setting for you.
http://www.48bitlba.com/enablebiglba.htm

Back to Hardware Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums