General discussion

Locked

Windows 2008 Activation TIP

By mikemc3 ·
I am a network engineer and for a over 20 days we had an issue where we could NOT get Windows to Activate. We had this issue for nearly a month and the trial Activation period of 30-days nearly expired. I tried to run slmgr.vbs -aco tried -dli switch to pull up the activation information, also tried the standard activation wizard too no avail. We got access denied error messages. We FINALLY found the answer.

Windows activation is actually tied to the "Plug and play" service and you need to give the system account called "Service" access to this service (we gave it full-control permissions). Once done we were able to Activate windows and do all the licensing goodness.

How did we do this you say..
Launched MMC and added the "Security Templates" and the "Security Configuration and Analysis" plugin. Created a new template (blanked out options) using the Templates plugin. Using the other plugin opened a new Database (named it Activation fix) and imported the new template created earlier. Analyzed the computer to bring up the security options then configured the "Plug and Play" service permissions by adding the local "Service" account and giving it full-control perms. Then configured the computer (another right-click option is Security Configuration and Analysis), this will apply the changes. Close everything and choose whether you want to save the MMC setup (doesn't matter).

Once done, you can now activate the system...BAMM :)

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

good tip... question:

by pgit In reply to Windows 2008 Activation T ...

Did you manually shut out PnP (eg as a standard security measure) then discover activation depended on it?

If this behavior was "out of the box" then I wonder why I haven't encountered it. Seems you had to do something to which this was a result.

Curious.

Collapse -

Glad you asked :-)

by mikemc3 In reply to good tip... question:

A. Yes, this was "out-of-the-box".
B. After posting this, I discovered that after 5~10 minutes Windows would show as not activated again. Discovered that in the test OU we put the system object in, in AD we had a Group Policy object linked to it that had the PnP service permissions locked down.

After the normal Policy refresh period the PnP service permissions would reset to default. Fixed this by creating a custom GPO, unlinked the other one.

Now unfortunately I don't know why this happened to begin with, I am glad your experience was smoother because this shows this isn't some major glitch on Microsoft's part but some weirdness in our test environment.

We ran into this problem with both R2 version of 2008 and the pre-R2 version (we put SP2 on this one)..

Question for you, have you checked the permissions on the PnP service? I am thinking the 2008 install updates these permissions but because of our GPO problem it could not..maybe?

What Microsoft told me give the Service account the following permissions..
Query Status
Enumerate Dependance
Interrogate
User-Defined Control
Read

Collapse -

: \

by pgit In reply to Glad you asked :-)

Well, I can't imagine MS would ship a show stopper like that, but then I also can't believe they'd make an essential run time service like activation dependent on PnP!

I've jotted down the perms they suggested to you and will check what we've got next opportunity I have. I'd hazard a guess that those are the installation defaults.

Back to IT Employment Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums