Question

Locked

Windows 2008 folders not respecting groups permissions

By ThaSniper ·
Hello.

I just installed a Windows Server 2008 and made it Domain Controller.
Now I need to set some shared folders, to be accessed only by certain groups of users on the domain. I ended up with this problem:

Before any share, as Administrator I create a folder, and remove the permissions inheritance. I add full permissions for the group Administrators. Also set the Owner to Administrators. I login to the server as a user belonging to Administrators group (not Administrator). I try to access the folder but returns permission denied!
When I check the effective permissions of that user on that folder, it shows full permissions.
The same happens using other groups, except that if I add the group Users to the folder, I can access it!

Tried this scenario on other domain, on a Server 2003 Domain Controller and it went as expected.

Do you have a clue on what's wrong, or what's missing?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Solved

by ThaSniper In reply to Windows 2008 folders not ...

Hello.

Found the solution. It happens that UAC interferes with folders permissions too. But not only, it will interfere with ANY group restricted folder, admins or not. Except the Users group.

Turning off UAC solved the problem. UAC shouldn't come with a server. Or at least it should come disabled by default.

Basically, if you use UAC in a server, you can forget strict groups shared folders on that server. Pretty, isn't it?

Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums