Windows 7 no sound

By strawberry444 ·
I have installed Windows 7 Ultimate, it was a clean installation. Everything works fine except that there is no sound.I found a message which says that speakers aren't plugged in but they are and they worked until I ran Windows 7.
Also my audio card is
Realtek ALC882/D/M @ Intel 82801GB ICH7 - High Definition Audio Controller [A-1]
And i have installed some Realtek drivers but it doesn't seem to change anything.
PS-Additional info
Computer Type ACPI x64-based PC
Operating System Microsoft Windows 7 Ultimate
CPU Type DualCore Intel Pentium D 820, 2800 MHz (14 x 200)
Motherboard Name Gigabyte GA-8I945P-G (3 PCI, 2 PCI-E x1, 1 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN)

I hope that's enough information for you to give me some tips.
Thank you.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

1st thing

by Jessie In reply to Windows 7 no sound

Windows 7 does a pretty good job about detecting and installing compatible drivers, but I'd check the RealTek website for you Audio card and see if there's anything updated for Windows 7 specifically (Vista may work if they don't have anything Windows 7)

Also, in control panel, sounds, make sure your playback device is listed as RealTek. If your Realtek isn't listed under available playback devices, the system definitely doesn't like the installed driver.

Collapse -

Which version of 7 Ultimate is this?

by OH Smeg Moderator In reply to Windows 7 no sound

The 32 or the 64 Bit Version?

The 64 Bit Version is very finicky as to which Sound Drivers it uses and the existing 32 Bit ones Will Not work with it. You need the 64 Bit Drivers that Both Gigabyte and Realtech have available for download on their Web Sites.

However having said that I'm using the 64 Bit Version of 7 with the same Sound Device and didn't have any Issues with the Sound when I installed both the Beta and Trial Versions of 7 Ultimate 64 Bit. 7 is very good at finding the required Drivers as it installs.

But do as suggested above and check the Sound Devices in the Control Panel and make sure that the Playback is set to Realtech. It's possible that some installed software changed this or that the Windows Install fell over somewhere setting the correct Devices.

I've seen this happen with the Beta Version when I didn't start with a Blank HDD.


Collapse -

Still no sound

by strawberry444 In reply to Which version of 7 Ultima ...

Hi! thank you for the advice :)
It's the 32 bit version and i think all the needed drivers are installed.I checked and Realtek Digital Output is my default playback device but it says that the speakers aren't plugged in. What do i do so that my pc to recognize them because they are plugged?

Collapse -

Have you tried unplugging them

by OH Smeg Moderator In reply to Still no sound

To see if the M'Board reacts?

When I first installed the 64 Bit version I had to unplug and then plug back in to set the type of Speakers that I had attached. I'm not sure if the sound worked prior to that but I don't think so.

Rather than being a Driver Issue I think it was something to do with the way that the Realtech Drivers work. After they get installed you need to then tell the Sound Card which speakers you have installed like Stereo Speakers, 5.1 Surround and so on.


Collapse -


by strawberry444 In reply to Have you tried unplugging ...

yes, I unplugged them and plugged them back but nothing happens...like I hadn't touched anything

Collapse -

Defiantly something wrong with the driver then

by OH Smeg Moderator In reply to yes

When you unplug or plug in any thing at all you should get a Window Open that asks what you have just plugged in or tell you that you have unplugged whatever.

The only thing I can think of here is that somehow the wrong drivers where used are you sure that you used the 32 Bit 7 Driver?


Collapse -

Windows 7 played merry **** with my sound until ...

by OldER Mycroft In reply to Windows 7 no sound

I checked which 'speakers' the Realtek system was thinking I actually had.

For some reason, Windows 7 had assumed my tower's front outputs (the ones for my headset, usually only ever used for Skype phonecalls) were my main speakers.

Check 'which way round' your speakers are orientated.

Collapse -


by strawberry444 In reply to Windows 7 played merry he ...

sorry about the dumb question but how to check which are my main speakers? :)

Collapse -

I'm not running a copy of 7 right now, But,

by seanferd In reply to umm

try right-clicking the tray volume icon, select Adjust Audio Properties, click Advanced under Speaker settings. (This using XP - 7 may Be slightly different.)

Check also that the default device is the expected sound card.

Collapse -

Thanks for the reply :) I checked and

by strawberry444 In reply to I'm not running a copy of ...

the default device is Realtek.Also I right clicked the icon and the settings I found for the speakers were for the volume control.I ticked the speakers but the problem remains.

Related Discussions

Related Forums