Question

Locked

Windows 7 permissions question

By Slayer_ ·
I have Windows 7 home prem


I am noticing if a program is installed with an installer (or with Install in its title, such as with winrar archives) that the files some how get locked into permissions I cannot alter,, even with UAC turned off, even if I am the true administrator (unlocked using "net user administrator /active:yes").
I always get permission denied on the files, but I can play with the folders ownership and permission, but the permissions won't propagate down.

For example, I want to change the permissions for Avira to disable the notify, but I cannot. I even tried installing to a blank drive root that had everyone as full control, and even that didn't work.

Is this some sort of block that can only be bypassed by upgrading to professional?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

wow that is interesting

by markp24 In reply to Windows 7 permissions que ...

Have you tried rebooting in safe mode Another way that may work is to boot with a UBCD4win and see if altering the ownership/permissions through that help. It almost sounds like Avira has built in protection?
One other thing, can you disable the Avira service (ig there is one) then change the ownership/permissions and /or alert settings see if that works,
Im going to keep looking around , this is interesting.

Collapse -

Reponse To Answer

by Slayer_ In reply to wow that is interesting

I'll try safe mode and get back to you.

Collapse -

version 12.0.0.872 (disable avnotify.exe)

by mario.jimenace In reply to Windows 7 permissions que ...

- right-click avira's system-tray icon
- select configure...
- enable expert mode (this is how I did it--this could be unnecessary); when enabled, the universal sign for power (pipe sign) will be reflected
- expand the General section
- select the security subsection
- disable "Protect files and registry entries from manipulation"
- make desired permissions edits
- reenable "Protect files and registry entries from manipulation" *

* changes can be made on-the-fly, however file protection will not be reenabled until a reboot is achieved for the system (according to the program)

Your friendly neighborhood ProGrammar

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums