Question

Locked

Windows 7 & running logon scripts

By phil.cowling ·
I've just installed Windows 7 Professional on 3 computers.

I work in a school that has two networks that are different domains and on separate subnets. The computer in one domain has a logon script that works perfectly, but the 2 computers in the other domain don't run their logon scripts at logon (although one of them used to work perfectly under W7RC - I've rebuilt that from the ground up with deletion of partitions, formatting of hard drive etc.)

When this first happened, I tried running the logon scripts manually by browsing to the netlogon share on the DC and running the BAT file by double clicking on it. A command prompt window appeared, the script ran, but the drives don't show in My Computer.

The scripts only map network drives, are in the netlogon share on the DC and are .bat files.

Both Domains are controlled by Active Directory and Group Policy so there is a possibility that the drives may not be showing because of a setting in GP, but I can't see one.

Does anyone have any ideas on what could be happening and how I can get the drives mapped in My Computer.

Thanks in advance for all your help.

Phil C
GM School

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try deleting the drives first

by dpalsen In reply to Windows 7 & running logon ...

Run the command "net use delete *" at the beginning of the script. If that still won't map them, try using the IP instead of the server name in the command. I have a couple of PC's at work that won't map if I use the computer name, but if I use the IP they will.

Also, what error # is it giving you?

Collapse -

Still not working!

by phil.cowling In reply to Try deleting the drives f ...

Thanks for the suggestions - I've tried adding the net delete command to the BAT file, No go!. I've tried adding the IP address to the BAT file - No go!

I've disjoined the machine from the domain where the logon scripts don't work, joined the machine to the domain where they do, and hey presto, drives get mapped.

I've rejoined the machine to the domain where the scripts don't work, created an OU in AD, blocked policy inheritance, forced a refresh of group policy and guess what, No go!

I'm now getting really baffled, and am trying Microsoft updates as that's about the only thing I can think of. Help!

Collapse -

look at your Windows 7 Network and Sharing Center settings

by CG IT In reply to Still not working!

Network discovery and Files Sharing must be turned on. Also look at firewall settings either using the Windows firewall or whatever 3rd party provider your using.

But I've had problems with Windows 7 because of the Network and Sharing Center. It automates quite a bit and doesn't really provide manual configuration like XP did. While MS says it's more secure it's a pain.

Scripts are supposed to run and make connections for mapped drives but if the Network and Sharing Center blocks the connection, then out of luck.

Collapse -

Fixed it

by phil.cowling In reply to Windows 7 & running logon ...

I've found the answer. The login script had a switch Persistent:No - as soon as I removed the switch, the login script worked. I don't understand why, but it did, so I'm happy now.

Phil C

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums