General discussion


Windows 98 TCP/IP TTL not playing nicely

By gza ·
Hi All

I have a Windows 98 SE PC that is not playing nicely. It is setup on a network with a linux server acting as firewall and gateway. The linux server has transparent masquerading setup for the workstation PCs and squid proxy server. The workstation PCs can either connect directly to the internet using the linux server as their gateway address and dns. They can also connect via the proxy server.

The problem PC cannot connect to anything when using the linux server as a gateway. Setting up the proxy server allows access however. The problem PC can ping any machine and communicate with any machine on the LAN without a problem. I have run tcpdump on the linux server and have picked up that the problem PC is using a TTL of 0 on all its TCP/IP packets! Other PCs on the LAN (also Win 98 SE) use a TTL of 32. I have found the registry setting that controls this, but it is correct on the problem PC.

Anyone have any ideas on:

1) Why Win 98 would use a TTL of 0 on its TCP/IP packets?

2) How to stop Win 98 from doing this?


This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Windows 98 TCP/IP TTL not playing nicely

by sgt_shultz In reply to Windows 98 TCP/IP TTL not ...

wow. this is cool. did you try static ip address on the problem pc? does that work? try using a NIC from one of the non-problem pcs...

Collapse -

Windows 98 TCP/IP TTL not playing nicely

by gza In reply to Windows 98 TCP/IP TTL not ...

I have tried so far:

1) Swapping NICs ... no change whatsoever
2) Changing IPs (static addresses are used) ... again no change
3) Re-installing TCP/IP ... still no change

I think my most likely solution is to backup, format, re-install ... but I would like to find out why this PC is doing this.

Collapse -

Windows 98 TCP/IP TTL not playing nicely

by aquaris In reply to Windows 98 TCP/IP TTL not ...

1- can the Linux server Pc ping the trouble one..

and what is the TTL for it there..

2- are you using any proxy/sharing software..
if so does it has any diagnostic utilities in it..
if so have you used them..

3- visit the you might find some utilities which will accurately diagnose...and maybe remedy your problem..

hope it helps...

Collapse -

by ryder007 In reply to Windows 98 TCP/IP TTL not ...

Have you tried updating the winsock? You can go to Microsofts website and get the update.

Collapse -

by chip35 In reply to Windows 98 TCP/IP TTL not ...

I suspect the machine needs cleaning (windows is a clutterbunny). There is much software out there that modifies the TCP/IP Stack to intercept the internet connection and/or monitor it. Most often it is AOL or other advertizing software. They intercept but do not support all available methods of accessing the internet. At times I have had to delete all network connections in control panel-network, uninstall dialup networking from add/remove windows features etc. Then I had to edit the registry (Backup the registry by running scanreg) and delete HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSNP32
and HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
and HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2
Then reinstall networking (usually reboot and install the network drivers). If registry edit screws up run scanreg /restore afterwards

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums