Question

Locked

Windows Automatic Updates and Power User eating 100% CPU Cycles

By The Weekly Geek ·
Tags: Off Topic
I have this happening on a couple of computers.
Windows Automatic Updates are set for Friday 3 am.
Every boot the wuauserv runs no matter what.
If the user logged on is a Power User the svchost that wuauserv is in eats 98 to 100% CPU cycles for 5 to 10 minutes and then lets go.
At some point later (5 minutes to 2 hours) wuauserv tries again. This happens every day not just Friday.
If I log on as an Administrator the Windows Update still runs, finds nothing and quickly disappears.
If set for Friday why is wuauserv trying to run on every boot / reboot.
I have killed several processes out of this svchost (Wireless Zero, Windows Time, TCP/IP NetBIOS Helper, Remote Registry) and I have set to "Manual" Machine Debug Manager and DNS Client. All of this was a test and I still am at square one.

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Automatic Services

by gsquared In reply to Windows Automatic Updates ...

Is it set to start automatically when the machine starts in your services?

(Right-click "My Computer", click "Manage", go to "Services", scroll to the service you're checking, and see if it says "Automatic" in the start column.)

Collapse -

CPU processes at 100%

by The Weekly Geek In reply to Automatic Services

Yes, Windows Update is set to start Automatically. Isn't that part of the process?

Update!
As Administrator I do not have these issues.
I made the Power User an Administrator and he still has the same issues.

Outlook is also extreemly boggy when writing an e-mail or reading new e-mail. Previously viewed e-mails are speedy.
If I crash Outlook then the Microsoft error system sends me to a page that blames Symantec WinFax Pr.
There is no Symantec anything on this system.
BTW This is a fresh format and install.
Windows XP Pro, Office 2k3 Pro all updates on both.
On Outlook I removed Spam Bayes - No Change
I cchanged NOD32 Anti-virus settings way down - No Change
I terminated AVG Anti-Spyware and Java Just Check Scheduler - No Change.
Using Process Viewer I was able to stop the CPU usage during boot (Manually) by going into the SVCHost and killing a file called "ntdll.dll!RtlAllocateHeap+0x18c"
This however does not solve the Outlook issue.
I tried to run Windows Updates. Active X was turned off in teh Browser settings, I set all back to default. This might have been Spybot, AVG Anti-Spyware, NOD32 Anti-virus) they are the only security programs (we use Windows Firewall).
On the Windows Update site under the Scheduled update time it had "everyday 3 am" but going under the control panel to the Security settings it was still "Friday 3am" I changed the Windows Update site to show Monday 3am. Ist still is constantly trying to update.
After 1 hour and 30 minutes (and counting) The Windows Update stide ist still at the "Checking fo the latest updates for your computer.." with the scrolling bar.
Even thoug I had removed SPAM Bayes and rebooted, the toolbar was still in Outlook. I removed it fia the "toolbars" check box.

Now, with Outlook eating 100% CPU cycles I can change its priority via Process Explorer". If I put it at the lowest process "6" (Not idle) I see no changes (by default it is in Normal "8"). If I move the priority to the highest (Real time "24") then even the mouse freezes up.

Collapse -

7 Days of Xp Makes 1 Week!

by Blau67 In reply to Windows Automatic Updates ...

Hey Weekly, if it is not important to you for Microsoft to decide what and when you receive updates then try this: Open Windows Security Center and click on "Automatic Update", then where it states; "Notify Me but Don't Auto Download or Install", Choose it! This will allow you to know what is available, choose what & when to download and install it! I have found that if Security Center Auto Update is set to automatically update at a certain time, then it will try for quite a while(function looping ****) to contact MS & download the updates! Quite often the server is overwhelmed at MS and it just can't serve ya! I find between 2 & 5 am is a good time to dnload ups! You can set the task scheduler to do this to circumvent letting Security Center handle it! Leave the Automatic Update enabled & on automatic in the services control panel but disable the following one at a time; Fast User Switching,, Terminal Services ! There are others but, I would start there ! Also, look in the registry for any "Symantic": entry then delete it after making sure there is no prog using it even though you said there wasn't any of that software on the puter!! Try this and post again ! It is a possible set of solutions! Good Luck, Blau

Collapse -

Weak Weekly Geek

by The Weekly Geek In reply to 7 Days of Xp Makes 1 Week ...

Well, I have another fresh install doing the same thing. The user has been "Administrator" since installation.
Everything was fine until I ran the latest set up optional Windows XP updates (several were just listed as "XP Update" and the NET 2.0.
The changing the Automatic updates did not help.
Disabling the services did not help either.
The file causing the problem is "ntdll.dll!RtlAllocateHeap+0x18c"
Sometimes two instances are running.

Collapse -

More information on issue.

by The Weekly Geek In reply to Windows Automatic Updates ...

The problem item in Widows is ntdll.dll but in Outlook it is Outlook.exe.
I have some screen shots of Process Explorers findings however, I do not know how or even if we can post them. If anyone cares I can post them to my web site.

Collapse -

Windows Update Prob

by Blau67 In reply to Windows Automatic Updates ...

Hello All!
~This seems to be happening to many others based on input I am receiving from associates of mine! I finally "corrected ?" it on my system by going to 'Services' and stopping 'Windows User Mode Driver Framwork' service and setting it to 'Manual'. I am embarrassed to say it but, I can't for the life of me figure out why that worked! I do not know if that will work for any of you either but, it is worth the try! I have experienced no problems since stopping that service!

Good Luck and Happy New Year! Blau

Collapse -

Time to give it a try.

by The Weekly Geek In reply to Windows Update Prob

I'll be giving this a try tomorrow.
Did it help with the Outlook issue too?
I have not resolved this issue and had one client call today with the same problem and a fellow tech in a nearby town call this evening (Jan 3rd 2007) with the same issue.

Collapse -

Automatic Updates

by dave.greene In reply to Time to give it a try.

I too had the same problem with svchost consuming all my cpu cycles.

Through a process of trial and error, I appear to have fixed it by disabling Automatic Updates. Changing to "Just notify me" did not work.

I suggest anyone experiencing this problem stop the Windows Update service... I immediately saw the svchost process disappear and an increase in CPU idle time.

Collapse -

profile

by jamesatmaisonverre In reply to Windows Automatic Updates ...

If the machine is part of a network,log on as admin,delete the users profile and then get the user to log in as this refresh's the profile and the system.The problem appears to be a problem with the profile.If the computer is not on a network then create a new account for the user and delete the old one.

Collapse -

Possible profile issue.

by The Weekly Geek In reply to profile

1 machine is by itself, it connects to a router then the modem.
The others are connected to peer-to-peer networks.
Disabling Windows Automatic Updates helps but does not solve the issue.
Outlook hanging when any e-mail with any type of an attachment is opened is a serious pain.
I have disabled the AV and anti-SPAM programs without success.
The common traits are
Office 2k3 Pro
Spam Bayes 1.09a
NOD32 (though some have 2.51 and others 2.7)

Other than that machines are XP Pro or Home, Network printers or USB only printers.

Removing the profile did not work on the one I tested. As a matter of fact the origional post is now incorrect. This issue is now happening when logged on as Administrator.

Back to After Hours Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Forums