Question

Locked

Windows Cannot access the specified device, You may not have permissions

By Sue_yurt ·
I am having a problem trying to open an .exe file, Windows gives the error:
"windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item."

However, I am logged in as administrator (running Windows Vista).

I have tried right-clicking and can access the properties, there is nothing that I can find that indicates it's encrypted (unless I just don't know where to look). I can easily change the properties, but still can't run the file (same error).

Can anyone help?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Uninstall the....

by robo_dev In reply to Windows Cannot access the ...

Internet Explorer Enhanced Security component

You can disable Internet Explorer Enhanced Security in the registry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zonemap

In the details pane, right-click IEHarden, click Modify, type 0 (zero) in the Value data box, and then click OK.

Collapse -

No IEHarden in Zonemap?

by Sue_yurt In reply to Uninstall the....

Hi, thanks for your help.

When I navigate through the registry, following the exact path you provided, there is no IEHarden in Zonemap. The only 3 items there are:
(Default)
AutoDetect
UNCAsIntranet

There are also more subfolders within Zonemap:
Domains
EscDomains
ProtocolDefault
Ranges.

I'm a little reluctant to Modify anything unless I'm sure I have the exact right path...

Does this info help? - by the way, I think that you are probably on the right track - It seems like it is a security related issue as the files I am trying to open do have viruses attached - but I only need them to work for a second, after which time I can re-enable my virus software and eliminate the threat.

Thanks again....

Collapse -

So you're trying to run virus-infected executable files?

by robo_dev In reply to No IEHarden in Zonemap?

You might want to run them in a SandBox, e.g. SandBoxie, unless your intent is to damage the computer OS.

It's entirely possible that the Virus is trying to do something bad such as directly modifying the Boot sector, and Windows won't allow it.

Collapse -

A few things to take a look at.

by Nimmo In reply to Windows Cannot access the ...

Take ownership of the folder it resides in, check your permissions (if there are special permissions take a look at them). See if the folder is inheriting permissions from parent folders, make sure the folder is accessible too.

Collapse -

I have all permissions....

by Sue_yurt In reply to A few things to take a lo ...

I did try to make sure I had all permissions on the file itself, but didn't try the folders so thanks for the suggestion. I did try it of course but it's still not working...

I do believe it is a security related issue as the files I'm trying to run are blocked by Norton - I can actually get a little farther when I temporary disable my Antivirus - but still run into the exact same Windows error message when trying to execute the file....

Collapse -

Did you.

by Nimmo In reply to I have all permissions... ...

When you take ownership of the folder where the .exe resides did you after you finished modifying the permissions check the box that says to apply these settings to sub folders?

Also good idea to drop norton (can't stand norton it always screws around with security and connectivity) also drop the windows if you haven't already tried.

Collapse -

turn off the mcafee and install any software will work

by melrub In reply to Windows Cannot access the ...

in mcaffe disable access protections and install the programs when you done
reenable the accesss protections back

Collapse -

If they haven't fixed it by now

by NexS In reply to turn off the mcafee and i ...

I'm sure they don't particularly mind.

You eat brains like the worst of them.


"Necroposting."

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums