General discussion

Locked

Windows Explorer checking CDROM drives

By chrisheart ·
When I start Windows Explorer for the first time, or any other programs "save as" for the first time, I have a long wait if I have disks in the CDROM drives.

How do I disable this ? I know there is a way but cannot recall it.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Windows Explorer checking CDROM drives

by TheChas In reply to Windows Explorer checking ...

The best tip I have, is to never store or retrieve files from within application programs (other then file managers) to / from the CD drive.
Windows stores the last few days worth of file history as links in the windows\recent folder, and as links in the programs registry and inf settings.

You can easily empty the recent files folder to get rid of those links.
It is not to difficult to search the registry for links to the CD drive (D:) and delete them.

The next thing to do,is to disablefast find. Fast find is installed by default when you install MS Office.

Chas

Collapse -

Windows Explorer checking CDROM drives

by chrisheart In reply to Windows Explorer checking ...

I was asking how to prevent the delay when clicking on "save as" - not saving to the CDROM drive.
The problem is the huge delay while windows does a scan of the CDROMS in the drives, (and the floppy but that wasn't really a problem) or when I open Windows Explorer (It scans the CDROM's then too). There is a setting somewhere (Registry ?) that puts a stop to this. I can't remember where though.

Collapse -

Windows Explorer checking CDROM drives

by Don Christner In reply to Windows Explorer checking ...

Make a backup of your registry before you do anything. Then, click Start|Run and then type Regedit and click OK. Then navigate to:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Then double-click the NoDriveTypeAutoRun value and change the binary vaulue to "95 00 00 00" (do not enter the quotes). Click OK and close the registry editor. You must reboot the computer for it to take effect.

Don

Collapse -

Windows Explorer checking CDROM drives

by chrisheart In reply to Windows Explorer checking ...

Thanks for your answer but it was already set to that value. I re-set it anyway, rebooted and it did not make any difference (
I had hopes too when I read your reply. <sigh>
Thank you for your effort.

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums