General discussion

Locked

Windows NT4 "AT" command

By sir_tuc ·
Using Win NT 4 with SP6a, on a PDC I am trying to shedule a script file to run every day at 05:30. According to Microsofts help file for the "AT" command it should look like this;
AT 05:30 /EVERY:M,T,W,TH,F,SA,SU C:\RUN\RUN.BAT
However, this onlyresults in a message that no commands were scheduled! What am I doing wrong?

Brian

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Windows NT4 "AT" command

by SteveD In reply to Windows NT4 "AT" command

Your syntax looks perfect. Make sure that the Task Scheduler service is running.

I hope this helps.

Steve Diamond

Collapse -

Windows NT4 "AT" command

by SteveD In reply to Windows NT4 "AT" command

One more thing: Also make sure you have administrator privileges on the PDC. But if you didn't, the message you would get is Access Denied.

- SD

Collapse -

Windows NT4 "AT" command

by sir_tuc In reply to Windows NT4 "AT" command

I am sorry but I forgot to mention that I had started task scheduler prior to using the AT command.

Collapse -

Windows NT4 "AT" command

by VinnyD In reply to Windows NT4 "AT" command

Try your command like this:

AT 05:30 /EVERY:M,T,W,TH,F,SA,SU "C:\RUN\RUN.BAT"

Collapse -

Windows NT4 "AT" command

by sir_tuc In reply to Windows NT4 "AT" command

I did try this but to no avail. Thanks for the suggestion.

Collapse -

Windows NT4 "AT" command

by stevej In reply to Windows NT4 "AT" command

An additional way of shcedulings this type af activity is through the use of the NT Server Resource Kit utility WINAT.exe. this utility provides the same functionality as the AT command, but it provides a much easier to use graphical interface for you to use. having had sytax and other errors using the AT command, I now use WINAT for any task scheduling needs instead of AT

Good Luck
SteveJ

Collapse -

Windows NT4 "AT" command

by sir_tuc In reply to Windows NT4 "AT" command

IT Worked!! Thanks a ton.

Collapse -

Windows NT4 "AT" command

by Astute In reply to Windows NT4 "AT" command

As already told pls make sure that schedule service is running. A common problem is that the example given in the online help: AT sometime CMD /C DIR > TEST.OUT.

Unfortunately, in NT 4.0, this does not work anymore. You must use AT sometime CMD /C \"DIR > TEST.OUT\" instead.

Note: You must now include an escaped quote before the command and after the file name you are redirecting the output to.

The execution of the command starts by default in %systemroot%\system32, as can be seen from the output of the above example. You should specify the complete path if the command is in a different directory, e.g. AT sometime C:\TEMP\TEST.BAT. A further problem is that the command is executed in the security context of the LOCAL SYSTEM account, not the caller. However, the SYSTEM account does not have access to network resources, so your program cannot reside or access files on mapped drives (even if they are mapped from the local machine!). Also, environment variables (e.g. PATH) may be set differently. You can test the environment interactively with AT sometime /INTERACTIVE CMD.

The AT command in NT runs under the SYSTEM account and therefore has no privileges to the network resources. (i.e. Can't write or read a file from the network). But if you go into Control Panel - Services - Scheduler and change the "Log On As" to a user that has the appropriate permissions (a user with access to the network), then an AT command that runs can actually use the network. This may be useful if you find submitted jobs are failing at certain network operations.

Hope this helps
Thanks
sharan

Collapse -

Windows NT4 "AT" command

by sir_tuc In reply to Windows NT4 "AT" command

Using the quotes did not help. I am not sure about the /c in front of <path> or UNC, what does it do? And for some reason the "Log On As" is greyed out, I can't change it. I can tell you know more about script files than me but no help for me. Thanks for your attempt.

Collapse -

Windows NT4 "AT" command

by McKayTech In reply to Windows NT4 "AT" command

Microsoft has a pretty good article on their TechNet site about troubleshooting the AT command (article #Q142040).

I agree with another answer offered that checking to make sure the Schedule service is running, but also check to see if the TaskScheduler that is part of IE5 has been installed.

If so, I believe that AT is essentially disabled and you'll have to use Task Scheduler (not to worry - it's a much better program anyhow...). See article Q235536 for the scoop on Task Schedulerwiping out AT.

Or if you decide to abandon AT and go with Task Scheduler, it is installed when you install IE and choose the Offline Browsing Pack option.

paul

Back to Windows Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums