Question

Windows (on Mac) won't start after installing new RAM

By Gidoza ·
Hello there,

So I have an iMac early 2008 and eventually realized it was pushing its limited using only 1x2 GB of RAM, so I purchased some new 2x2 GM RAM (exactly the same in every way, but 2x2 instead of 1x2) and installed the RAM.

I run the Mac OS, but I also have BootCamp installed with Windows 7 and use Windows probably more often for a variety of things.

Anyways - the Mac side; no problems, it gobbled up the RAM and loves it.

The Windows side - at first, it was confused. It refused to start up and gave lots of error messages. After a couple restarts, it started running just fine (this Windows 7 is 32-bit), but with only 3 GB RAM due to the 32-bit. For two days there was no problems.

Now, 2 days later, after a fairly standard Windows crash which can happen sometimes: I had to force shutdown the computer. Upon trying to boot it up again - Windows utterly refuses to do it. It just reboots itself on an infinite loop, even in safe mode, OR it will just hang there and do nothing. I suspect this has something to do with the RAM, as I've never had this issue before.

Any thoughts? I have a new SSD I'm going to install soon and there's some pages some people have written on how to put Windows 7 64-bit on this kind of Mac...but in the mean time, how do I access my Windows again? :)

Thanks so much and take care,
-Gidoza
0 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Hardware Forum
0 total posts (Page 1 of 1)  

Related Discussions

Related Forums