Question

Locked

Windows Server 2003 R2 with Remote Desktop Admin - Can't connect, no error

By mark ·
Using Remote Desktop Connection in Vista, I used to be able to successfully connect to a couple of servers running Windows Server 2003 Enterprise running Remote Desktop Admin (not full Terminal Server licensing in place).

Both of these machines were upgraded to Windows Server 2003 R2. Now, when a Vista (or XP for that matter) client tries to connect to either of those servers with RDC, they find the server (name resolution seems to work), and I'm prompted for credentials. The RDC applet greys out as if it's about to connect, then about 1 second later, nothing happens and I'm back to the RDC prompt (asking me for the server name again). No error. This occurs on both of the R2 servers (both running Enterprise, one is a domain controller, the other is not).

RDC functions fine when connecting to non-R2 2003 servers.

I don't show anything in the security log for these R2 servers that show that credendials were wrong. If I purposely enter the wrong credentials, the same effect, no prompt that the credentials were wrong.

DNS seems to be fine as I can ping and remote connect to these machines using other remote control software (Radmin). I've tried un-installing that thinking it was a problem with R2 and the video hook drivers, but no luck.

Firewall settings on the R2 servers also show that Remote Desktop is enabled as an exception. I've also tried completely turning off the firewall, no luck.

Terminal Services Manager is running fine and showing that RDP-TCP listener is running.

Thanks all.

This conversation is currently closed to new comments.

24 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Enabled

by retro77 In reply to Windows Server 2003 R2 wi ...

Is RDP enabled on the server? My computer, Properties...yada yada...

Collapse -

RDP enabled

by mark In reply to Enabled

Yes, RDP enabled is enabled. If it disable it, I get the usual error from the client indicating it can't connect, but when I enable it, I don't get that error, but I get the strange behaviour (like it's just ignoring it or can't draw the screen, no error). Thanks retroman.

Collapse -

One Thought

by retro77 In reply to RDP enabled

You have a group in there as having permissions and the group contains the user account that your are trying to connect with.

Also try not connecting at full screen, dont bring your printers from your client...also set it to not redirect sounds. Try turning all that off and remoting again.

Event viewer: getting errors on either side?

Collapse -

RDC client - no local resources

by mark In reply to One Thought[s]

Hey retro, I'm using the domain admin username/password, and tried the local 2003 R2 server admin who have TS privlidges. I tried not using full screen, also turned off forwarding of all local resources like printers and clipboard and sounds, still no luck.

Event viewer isn't generating any errors on either side of the fence. I'm guessing something unique in 2003 R2 vs. regular 2003 has messed up RDP. This machine has no software on it either, just a vanilla install of 2003 enterprise server, then applied all updates, RDP ran fine, then upgraded it to 2003 R2, and this started. What's weird is I can duplicate it on 2 other machines, all different brands (HP server and another a Dell), same effect, one of them is a web server, same problem with that one, once it got upgraded to R2, no RDP anymore. I verified that 2003 R2 does not require full Terminal Server licencing, it still comes with the remote desktop for administration free license (2 per box I think to allow 2 users to RDP into the machine for admin purposes using RDC).

Thanks for all your help.

Collapse -

RDP is finally working, removal of ATI Catalyst Suite did the trick

by mark In reply to One Thought[s]

Hi Retro, just wanted to thank you for your assistance, it ended up being the ATI Catalyst Suite which is installed with the video driver (these servers have ATI Radeon X550's in them).

Removing the Catalyst Suite and using just the ATI driver alone did the trick. Don't know why as the Catalyst doesn't change the video driver, it just gives you a control panel utility. Go figure.

Thanks again,
Mark

Collapse -

THANK YOU

by sina.ebadi In reply to RDP is finally working, r ...

I had the same problem and your final comment did help me!!

Collapse -

Reponse To Answer

by slagvd In reply to Enabled

Thanks retro77, you helped me sort this out after YEARS of nuisance. In my case, I had to change colour depth from 32bit to 24bit. Presumably some graphics card incompatibility. So there is a god...

Collapse -

Might seem to easy but...

by scott_heath In reply to Windows Server 2003 R2 wi ...

Have you tried restarting the service? Can you telnet to port 3389 on the boxes in questions? Can you access them from an XP box with RDC 6.0?

Collapse -

Restart services and telnet

by mark In reply to Might seem to easy but...

Hi Scott, I have the same effect when trying to access these 2003 R2 boxes from XP as well. I don't see a RDP service to restart, the only services I see are Terminal Server (which can't be stopped or re-started), and Remote Desktop Helper Service, which I restarted, but no luck. I don't have telnet service running on these servers. Port 3389 is open as I completely disabled the firewall on the R2 machine to rule out firewall issues.

When this machine was just regular 2003 Enterprise (not R2), it had no problem with remote desktop administration, but now that it has been upgraded to R2, I get this strange side effect, which behaves unlike anything I've ever seen when remote desktop just doesn't connect. This one seems to connect, but won't display the screen.
Thanks again for your help!

Collapse -

doh

by scott_heath In reply to Restart services and teln ...

I forgot you can't restart the terminal server service. Have you rebooted the box?

Were you able to telnet to port 3389? You don't need a telnet server running, if the port is listening it will connect. If it won't then there is either an issue with the service or maybe there has been a network change. Does the communication have to cross routers?

Back to Windows Forum
24 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums