Question

Locked

Windows Server 2003 Serious Problem, Doesn't Load

By ohm.paul ·
I made a serious mistake by editing some Security permissions on the C: and drives of my windows server 2003 server. After doing so, I restarted the computer, and now before the login prompt appears, it says that "At least one service or driver failed to load during system startup." Then, when I try to log in with the Administrator account, the login prompt goes away for a split second and then reappears, seemingly doing nothing. Also, Safe Mode performs the same way.

I imagine that crucial services are unable to load, and now I am in a very bad predicament. Does anybody know of a way to recover from such a situation? I have a system backup on tape drive, but I cannot get into windows to use it. I have tried loading the Windows Server 2003 R2 cds and loading them, and trying to "Recover the existing OS" but it tells me that I have no Hard Disks installed...(I have 5 hot swappable SATA drives in the Server).

Can anyone give me any kind of help? I am not really sure where I can go from here except reinstalling the entire OS which would mean losing some recent work...

Thanks,
Paul

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Do not know what you have done. But the only way is.....

To load on the operating system on another drive and then you will be able to access your data from the drive(s) in question, or at least you will able to do a backup from your tapes, but save the data from the drives first. then do a restore from tape.

http://www.computerperformance.co.uk/w2k3/disaster_recovery_backup.htm
http://www.computerperformance.co.uk/Litmus/backup.htm

How to install System restore on server 2003

Below i will show how to do this after server 2003 is installed. I haven't tried slipstreaming this, but i imagine it could be done easily. If there's enough interest i might show how to slipstream system restore into server 2003.

Before we begin, you'll need an XP CD. Doesn't matter if it's home or pro. It shouldn't matter if it has a service pack on it, since all the files will be the same source. In testing i used a slipstreamed cd that already had sp1 on it.

In XP, system restore is installed in syssetup.inf under the inf.always section. If you have XP installed, you can open up %windir%\inf\syssetup.inf and search for [Infs.Always], you'll see the section xp looks at for installing system components. You'll notice it has sr.inf, this is the inf for system restore. For server 2003, if you look at syssetup.inf you won't find sr.inf. This doesn't mean system restore won't work in server 2003, it just means they didn't install it.

So first what we're going to need to do is right click on sr.inf and select 'install', to install it on server 2003. If you have xp installed on another computer/partition you can just right click on it. If you don't, then extract \i386\sr.in_ from the XP cd to your desktop, then right click on it and select 'install'. It'll prompt you were the files are, point it to the XP CD. Once done, it'll prompt to restart, say yes.

That was easy, the next part is the tricky part. After restarting you'll get an error saying the service couldn't start. Specifically the error is error 1068. I searched google and found this link - http://www.aerdyne.com/Kbase/article_000005.htm. The error basically means it cannot run under the service it's on. In system restore's case, it runs under the network service. I know this because in services.msc, for path to executable, it says this: C:\WINDOWS\system32\svchost.exe -k netsvcs. This got me thinking so i opened up sr.inf, and found this line:

[SRSvc_delreg]
HKLM,"Software\Microsoft\Windows NT\CurrentVersion\SvcHost","SRGroup"

I opened up regedit, and this registry key didn't exist. So it seems the sr.inf doesn't register system restore to run under the network services group. Using the above registry key as an example, i opened regedit and went to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost

On the right hand side i saw netsvcs. I double clicked on it, but saw SRService no where (SRService is the name for system restore). On a hunch, at the bottom i added SRService, rebooted, and this time got no error on startup. I opened up rstrui.exe, and system restore opened fine. I also had a System restore tab in system properties now too. I was able to make a restore point fine, then restore the computer to it without any problems. So in the above key, you want to double click on netsvcs, and at the bottom of the list, you want to type in SRService (probably case sensitive).

If you're not good with the registry you can save the following as a whatever.reg file and import it, but because it's binary i can't say if it'll work. I recommend manually adding SRService to the netsvcs key.

---copy below to whatever.reg then double click on it -----

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost]
"netsvcs"=hex(7):41,00,70,00,70,00,4d,00,67,00,6d,00,74,00,00,00,41,00,75,00,\
64,00,69,00,6f,00,53,00,72,00,76,00,00,00,42,00,72,00,6f,00,77,00,73,00,65,\
00,72,00,00,00,43,00,72,00,79,00,70,00,74,00,53,00,76,00,63,00,00,00,44,00,\
4d,00,53,00,65,00,72,00,76,00,65,00,72,00,00,00,45,00,76,00,65,00,6e,00,74,\
00,53,00,79,00,73,00,74,00,65,00,6d,00,00,00,48,00,69,00,64,00,53,00,65,00,\
72,00,76,00,00,00,49,00,61,00,73,00,00,00,49,00,70,00,72,00,69,00,70,00,00,\
00,49,00,72,00,6d,00,6f,00,6e,00,00,00,4c,00,61,00,6e,00,6d,00,61,00,6e,00,\
53,00,65,00,72,00,76,00,65,00,72,00,00,00,4c,00,61,00,6e,00,6d,00,61,00,6e,\
00,57,00,6f,00,72,00,6b,00,73,00,74,00,61,00,74,00,69,00,6f,00,6e,00,00,00,\
4d,00,65,00,73,00,73,00,65,00,6e,00,67,00,65,00,72,00,00,00,4e,00,65,00,74,\
00,6d,00,61,00,6e,00,00,00,4e,00,6c,00,61,00,00,00,4e,00,74,00,6d,00,73,00,\
73,00,76,00,63,00,00,00,4e,00,57,00,43,00,57,00,6f,00,72,00,6b,00,73,00,74,\
00,61,00,74,00,69,00,6f,00,6e,00,00,00,4e,00,77,00,73,00,61,00,70,00,61,00,\
67,00,65,00,6e,00,74,00,00,00,52,00,61,00,73,00,61,00,75,00,74,00,6f,00,00,\
00,52,00,61,00,73,00,6d,00,61,00,6e,00,00,00,52,00,65,00,6d,00,6f,00,74,00,\
65,00,61,00,63,00,63,00,65,00,73,00,73,00,00,00,53,00,61,00,63,00,73,00,76,\
00,72,00,00,00,53,00,63,00,68,00,65,00,64,00,75,00,6c,00,65,00,00,00,53,00,\
65,00,63,00,6c,00,6f,00,67,00,6f,00,6e,00,00,00,53,00,45,00,4e,00,53,00,00,\
00,53,00,68,00,61,00,72,00,65,00,64,00,61,00,63,00,63,00,65,00,73,00,73,00,\
00,00,54,00,68,00,65,00,6d,00,65,00,73,00,00,00,54,00,72,00,6b,00,57,00,6b,\
00,73,00,00,00,54,00,72,00,6b,00,53,00,76,00,72,00,00,00,57,00,33,00,32,00,\
54,00,69,00,6d,00,65,00,00,00,57,00,5a,00,43,00,53,00,56,00,43,00,00,00,57,\
00,6d,00,69,00,00,00,57,00,6d,00,64,00,6d,00,50,00,6d,00,53,00,70,00,00,00,\
77,00,69,00,6e,00,6d,00,67,00,6d,00,74,00,00,00,77,00,75,00,61,00,75,00,73,\
00,65,00,72,00,76,00,00,00,42,00,49,00,54,00,53,00,00,00,53,00,68,00,65,00,\
6c,00,6c,00,48,00,57,00,44,00,65,00,74,00,65,00,63,00,74,00,69,00,6f,00,6e,\
00,00,00,68,00,65,00,6c,00,70,00,73,00,76,00,63,00,00,00,75,00,70,00,6c,00,\
6f,00,61,00,64,00,6d,00,67,00,72,00,00,00,57,00,6d,00,64,00,6d,00,50,00,6d,\
00,53,00,4e,00,00,00,53,00,52,00,53,00,65,00,72,00,76,00,69,00,63,00,65,00,\
00,00,00,00


--- copy above --------------------------------------------------------

That's it! Remember to restart both times.

Please post back if you have any more problems or questions.
If this info is useful, please mark it helpful. Thanks

Collapse -

Recovery

by ohm.paul In reply to Do not know what you have ...

Thanks for the info, I guess I will have to reinstall everything like you said on a diff drive, then try to access the others. Thanks for the info on installing system restore, I will probably do that after I get this all reinstalled, but it wouldn't really have helped me in this situation since I can't get into windows even...unless you can system restore before windows loads...

Collapse -

Yes you will have to start fresh..

Then add on the Restore option. It is trial and error in this situation. Sorry if it is complicated, i have put the post as easy as possible. :)
Hope all works out.

Please post back if you have any more problems or questions.
If this info is useful, please mark it helpful. Thanks

Collapse -

Windows installing on other hard drive

by ohm.paul In reply to Do not know what you have ...

Thank you very much for your help. I am currently installing WS2003 onto the other hard drive, and once it is done, I will hopefully be able to recover what I need and then use the tape to put back what was there.

One other question: how do I go about distributing the tape backup onto all of the 5 hard drives? They were set up in a 5/1 RAID configuration...Do I just copy the tape backup to each of the 5 drives or just to the main and then somehow tell it to copy itself to the remaining 4?

Thanks again

Collapse -

Restored Tape Drive

by ohm.paul In reply to Do not know what you have ...

Ok, well so far, I have loaded WS onto a spare HDD, gotten all of the data from the inaccessible drives by taking ownership with the new install of WS, and tried to restore from a tape backup. I would like to restore the tape backup to the original drive, so that I don't have to reinstall WS2003 on the original drives because that would save me a lot of time in the way of drivers, etc.

However, when I tried to use Symantec's Backup Exec to restore the tape to F: drive (which was the C: drive in the original configuration), it gave me an error about not finding a file. Then I tried restore to a folder on the desktop, and then copied the entire contents (entire contents of a normal C drive: Docs and Settings, Program Files, WINDOWS, etc) back to the F: drive. This seemed like it should work if I just remove the new install of WS and put in the original with the copied files, but when I went to boot, it gave me the "NTLDR is Missing" error. When I try using the Recovery console built into the Windows Setup disk, I press "R" and it says it cannot find any hard disks...which I know is untrue because if I go to the boot menu, i can select the Integrated Perc 6/i RAID drives as a boot method...am I missing something here?

Now I'm a bit stuck as I don't have the original contents of the C: drive as I overwrote them with the tape backup's copy (which should work...) So I am at the point where I guess I am forced to reinstall WS2003 afterall, but at least I got my recent work off of there...

Is there any reason why copying the contents of the Full tape backup of the system over to the main drive wouldn't work?

Thanks

Collapse -

any thoughts?

by ohm.paul In reply to Restored Tape Drive

is there anything I can do from here besides doing a reinstall of windows? I got all of the data that I needed from it, and the backups are being used on another server, so I have some time to fix it up, but I'd feel a lot better if it were exactly how it was.

Does anyone know why copying the entire C: from the tape backup over to the drive wouldn't work?

Collapse -

Can you remote in?

by IC-IT In reply to Windows Server 2003 Serio ...

Try remote desktop or look into xcacls.vbs from Microsoft. This allows remote permission changes.

http://support.microsoft.com/kb/825751

Collapse -

Another thing

by bart777 In reply to Can you remote in?

Before you go nuclear.

You said you changed file access. If you know what and where can you see them by going to the administrative share from another box in the domain? Can you take ownership and reset the security?

Collapse -

Take ownership

by ohm.paul In reply to Another thing

that sounds like a good idea, but I still have no way of accessing the files on the server from another box. I tried connecting as you would to a normal share on the server, but it can't reach the host as if the networking services on the server aren't being started. Remote desktop certainly didn't work either...

Collapse -

No Remote Desktop

by ohm.paul In reply to Can you remote in?

When trying to remote desktop in, it doesn't let me. The server doesn't even respond, but it worked before the problem. Xcalcs might be the same since I can't get into any form of windows to be able to install xcalcs...

Back to Networks Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums