General discussion

Locked

Windows Update error code Error 0x800A0046

By rsflea73 ·
Trying to run Windows update on a Win2K Pro box sometime after installing SP4 I got the Error 0x800A0046 error. Tried all the fixes that have been posted by M$ without luck. Tried the fixes I found through newsgroups, google etc such as RPC, BITS, auto updates etc to local and still no luck.
In the mean time my son, who thought he was doing me a favor, installed the WinXP Pro with SP2 upgrade I had purchased a couple months earlier but not yet installed. I hadn't installed it because I was trying to find a solution to the error I was getting. So now I have the same error showing on the now upgraded to WinXP box.
With both OS's I was getting the icon in the Sys Tray telling me an update was available from M$, but when I click on it it just goes away for approx 1 min and comes back.
I'm not a guru on M$ but can usually find my way around for soultions. This one has me stumped. I really don't want to have to format and re-install. Seems it would be easier to put in a new HDD and move what I want from the old if there is no solution for this.

This conversation is currently closed to new comments.

26 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Permition

by inekam In reply to Windows Update error code ...

I have googled the error and the first thing that poped up is the posible solution.

Are you running windows update as the local administrator?

What causes Error 0x800a0046

# The user logon account belongs to the Guests or Limited account groups.

# The security descriptor does not let authenticated users run Windows Update.

# The Impersonate a client after authentication policy is missing the Administrator and Service account from the list of Users and Groups.

To resolve this error, use one of the following methods:

Resolution Suggestion One:

# Remove the user account that is experiencing difficulty from the Guests or Limited account groups:

1. Click Start, click Run, type control admintools, and then click OK.
2. Click Computer Management.
3. Expand Local Users and Groups.
4. Select Users.
5. Open the account that is used to access Windows Update.
6. Click the Member Of tab.
7. Select the user account that you want to remove, and then click Remove.

Collapse -

Nope!

by rsflea73 In reply to Permition

I've tried that already. Even set up a new account as administrator only.

Collapse -

try this

by inekam In reply to Nope!

Unblock Windows XP updates
This script will run and clean out your windows updates
http://techrepublic.com.com/5138-1035-5915115.html?tag=nl.e103

Collapse -

Services?

by Paul Newell In reply to Windows Update error code ...

Do you have all the required services running that need to run to do Windows Update?

I believe you need to have the following in a 'Started' state to properly run Windows Updates:
-Automatic Updates
-BITS
-COM+ Event System
-RPC
-System Event Notification

Good luck!

Collapse -

What worked for me...

by dtms320 In reply to Services?

Just rebuilt a customers box and got the same thing. I too tried all MS fixes and no luck. What worked for me was to get IE 6 and install it manually. After that update worked fine.

http://www.microsoft.com/downloads/details.aspx?FamilyID=1e1550cb-5e5d-48f5-b02b-20b602228de6&DisplayLang=en

Collapse -

fix for error 0x800A0046

by selinathe1 In reply to What worked for me...

I don't see anyone posting this so just in case...
I was getting 0x800A0046 in my users's Win XP sp2. Along with this error message, other symptoms are:
- Start > Search does not work
- Network Connection window is empty
- msconfig is not accessible

The solution was to set the following in Group Policy:
Comptuer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment
in the right pane, find "Impersonate a client after authentication" and add "ADMINISTRATOR" and "SERVICE".

we also had another symptom where windows installer cannot be accessed. I solved this by either re-registering or reintalling msiexec.exe.

hope this helps.

Collapse -

no fixes for Windows Update 0x800A0046

by thomastx In reply to fix for error 0x800A0046

I've had this same error, tried all fixes listed everywhere on the net. None work. I also have the problem of no interfaces showing up in Network Connections. I think something is up with DCOM security or something like that, but I don't know enough about it to troubleshoot it. I'm seeing this on a recently upgraded PC (2000 Pro to XP Pro SP2).

Another issue that is possibly related... When I open ANY service and click the Dependencies tab, I get an error "Win32: Access is denied.".

Help!

Collapse -

errro 0x800A0046

by selinathe1 In reply to no fixes for Windows Upda ...

you're right about DCOM. error code 0x800A0046 is cuased by permission issues. i found this site and i think it's pretty useful.
http://www.computerperformance.co.uk/Logon/code/code_800A0046.htm
as i posted earlier, if you change the seeting in group policy, it should give the user proper permission to run certin services.

"Impersonate a client after authentication" is introduced in XPSP2, and (i think) 2KSP3. in this permission, the default should have 'administrator' and 'service'. but for some reasons, it doesn't, all you have to do is to add it.

i was getting the same error (Win32: access denied) when i made a change in GP, it got solved all together. =)

lemme know how it works for you.

Collapse -

Any answers yet?

by jorabi In reply to no fixes for Windows Upda ...

thomastx,

I am having the exact same problem with a client pc as you posted back on 6/20/06.

Windows Update error, empty Network Connections window, Win32 error in Dependencies, etc.

Did you ever find the answer? I've been searching and trying everything, including everything listed here, to no avail. Arrgh!

Collapse -

Same symptoms ... and what fixed it for me

by GACrabill In reply to Any answers yet?

See http://support.microsoft.com/kb/910338/en-us

I have seen steps 3,4,5,6 at other places as 1,2,3,4. Step 1, sub-step 7 at above site involving DCOM security solved my problem. I went one step further than what was documented in step 1, sub-step 7 ... I added only one thing, the only account name on this computer as documented in step 1-7-d. This account by default is part of Administrators, but I figured that it couldn't hurt to add it .... and after a re-boot, Windows Update works and Network Connections looks like it's supposed to.

Back to Windows Forum
26 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums