Windows will not boot unless bootable CD is in Drive

By spiderz_a_killer ·
Hello all, my title says it all really. My PC (Windows Vista Ultimate, P5N32-E SLI MB, 8800 GTS)... i'm sure hardware wont be the issue, more along the lines of the SATA drive configuration?

I have 1 SATA drive, Partitioned so Windows owns the first partition then another partition for data.

I then Have 2 IDE drives, CD-ROM & HDD.

And the computer will only boot into windows with a CD that is bootable. Other wise displays a No OS Found error message.


Please help. Thank you =]

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Did you fit/format the IDE HDD after loading Vista?

by HAL 9000 Moderator In reply to Windows will not boot unl ...

If so the computer has defaulted to having the IDE Drive as the C Partition and is unable to find the Boot Files on the SATA Drive. You can check to see if this is the problem by temporally disabling the IDE Drive and see if the computer boots normally. If it does you need to do an In Place Install to write the necessary files to the IDE Drive so that the computer can find the Boot Files. Unfortunately the M$ Knowledge Base doesn't have any information on how to do this as Vista is still a very new product but if you follow the XP procedure it should work


Or you can post a question to the Windows Vista Community here


Or depending on the Chip Set Type on the M'Board you may be able to alter the default boot process to one of the SATA Drives and ignore the IDE Drive. But generally if you fit/format an IDE Drive after loading any OS you need to do a Repair Install so that the OS boot up files can be found.


Collapse -

No operating system.

This will be because you are missing the "MBR"( master boot record ). You will need to change the "sata drive" in your bios to the "ide disk" so this will be your master disk and then load on windows. Once loaded copy all your data (NOT system files or Os files) from the sata disk to your ide disk then do a copy (clone)of your ide disk to your sata disk (do a reboot of your ide disk first to make sure this is bootable) if all is alright you should be able to boot from your sata disk. Hope this works for you.

Collapse -

Hard Disk boot priority

by djharkness In reply to Windows will not boot unl ...

I had the same problem. Here is what worked for me.

The bios was set to boot from removable drives, then cd, then hard drive. All seems ok with this, however under further inspection I found that the hard drive priority (separate setting in boot area of the bios) was set with my raid array first and my system drive second. I moved the system drive to the first in the priority list and shabang it worked!!

Why does it work with the CD? Here is my guess: With the cd in the drive, it boots from the CD. Yeah it says "Press any key to boot from the CD..." and you ignore it, but really once it says that it has already booted from the CD. When you ignore the prompt it then tries to load the operating system from the first hard drive it sees instead of passing the booting back to the BIOS. I don't know if that is what really happens, but its my guess.

Related Discussions

Related Forums